Image Map Image Map
Results 1 to 8 of 8

Thread: Tandon TM100 motor off modification

  1. #1

    Default Tandon TM100 motor off modification

    Hi

    I need some expert advice! I've just tried to implement a motor off mod for the Tandon TM100 drive in my Superbrain.

    The modification is as follows:

    • Isolate the MOTOR_ON line with a piece of tape. The Superbrain has this wired to an inverter that is in turn connected to +5v, so it is always lo, so the motor runs continuously. This is the 8th tab from the left on the drive's PCB edge connector, with the drive oriented as follows: door facing away from you and the PCB on the top.
    • Link the HM jumper (the 8 -> 9 link on the jumper black). HS should already be linked in the Superbrain (it is).
    • There is an additional mod to the SB motherboard - swap a 27K for a 56k resistor to extend the head load delay to 250ms, giving the motor time to spin up.

    This was all documented in one of the Superbrain "Superletter" editions (Vol 3 No. 5) by Jonathan Platt.

    So, I've done all of this, but the motor refuses to spin up when the drive is selected. I've checked all the jumper settings with a meter and they are correct. The drive does have a 12v supply, and if I reverse the modification it does work (by running the motor constantly).

    There are alternatives, of course; the main one being to tie /DS to /MOTOR_ON so that the motor runs when the drive is selected, and again isolate the /MOTOR_ON line at the edge connector. Intertec used to do this (so I read), but it sounds a bit less reversible then the Platt modification (and you still need the resistor swap).


    What else can I check?

    Thanks
    JonB
    Last edited by JonB; June 19th, 2017 at 07:16 AM.

  2. #2

    Default

    Well, I jumped the gun and was looking at the schematics for an actual Tandon TM-100 from the TRS-80 Model 3,
    because I had a senior moment and couldn't locate my subdir with the SBQD Schematics.

    Now, I think you can just make sure the MX Jumper (Pins 6 & 9) is removed (OPEN) from the Shunt 2D. Then jumper Shunt
    2D for One of DS [1..4], along with MS Jumper (Pins 1 & 14) (CLOSED), with the MM Jumper installed, you will have to
    isolate the Edge Card Connector Pin 16 from the Floppy Controller. It should work correctly.

    REF: SBrain_SA450_2


    Larry
    Last edited by ldkraemer; June 19th, 2017 at 11:43 AM. Reason: updated

  3. #3

    Default

    Hi Larry

    Where can I get the schematic? I restored the jumper settings after attempting the Intertevh trick and the drive seems to have died. I need to debug it..



    Cheers
    JonB

  4. #4

    Default

    Good news! My drive isn't damaged after all.

    I'm not sure what happened, but this morning I switched it on and all is well. (Edit: the 5v line came adrift of the power supply)

    I redid the Intertec modification (drive select -> motor_on line) and it is now working.

    Phew, that's a relief.. now to order a super quiet fan (the one I put in there is noisy after all).

    I may need to power the drive's 12v line from a separate supply, though. The monitor is flickering slightly at motor start up, so the Intertec power supply is probably struggling a bit...
    Last edited by JonB; June 20th, 2017 at 05:38 AM.

  5. #5

    Default

    Oh sorry, forgot to say: Big thanks to Larry for sending me the schematics!


  6. #6

    Default

    JonB,
    No Problem. Just glad you got it working.

    One quick question for you. I think I've located the Resistor that is talked about in the Vol 3 Number 5 Supperletter and it appears to be R11.
    Is this the exact one you changed from 27K to 56K on the Motherboard? It would have been nice if the Article had named the exact Resistor.

    Thanks.


    Larry

    SB-R11.jpg
    Last edited by ldkraemer; June 21st, 2017 at 05:03 AM.

  7. #7

    Default

    JonB,
    In looking at an updated Photofacts Schematic of the Tandon TM-100, It looks like there could be a problem
    with using the Tandon TM-100 Series because of a missing circuit trace at Shunt 1E, Pin 1 for HS. (It may
    have been left off the Schematic, but you are going to have to check it to make sure it goes to the same circuit
    of the SuperBrain Floppy's.

    I've attached the information for Shunt 1E and the latest schematic that I had previously downloaded.


    Larry


    TM-100_Shunt-1E.jpg TM100-Shunt1E.jpg
    Last edited by ldkraemer; June 21st, 2017 at 05:05 AM. Reason: typo

  8. #8

    Default

    Well, first off, Larry, good spot on R11. I couldn't find it in the schematic (not looking hard enough, obviously), so I used Jonathan Platt's description of its location in the Superletter article. I replaced it with a 47K resistor, which doesn't give the full 250mS delay but is OK for now.

    Thanks again for sending the documentation - it's a good deal better than the datasheet, because it has all that diagnostic information and the schematic seems to match my drive's board more closely.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •