Image Map Image Map
Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Need replacement or reworked D12887 CMOS battery

  1. #11

    Default

    I reseated the ram and the DS12887 and still no post... hard drive starts up but still nothing on screen and no beep.

  2. #12
    Join Date
    Jan 2007
    Location
    Pacific Northwest, USA
    Posts
    25,032
    Blog Entries
    20

    Default

    So what happens if you pull the 12887?

  3. #13

    Default

    Absolutely nothing... as in no change from with it in.

    And if anyone has the correct DS12887 that will work in this thing let me know. As I've mentioned above the new one didn't work right.

  4. #14

    Default

    Though I did notice that earlier when I was trying the replacement DS12887 that some of the pins had broken off and it wouldn't post. I could somehow have messed up the old dead one that used to at least post. If I try a good DS12887 maybe it will post again.


    I ordered a 128 byte DS12887 so I'll try that. Hopefully it will post again.

    And if not... if there's someone that could repair my system... I would love to speak with you.
    Last edited by TravisHuckins; July 16th, 2017 at 07:54 PM.

  5. #15

    Default

    I would kill for a service/owner's manual for this thing... it might help.

  6. #16

    Default

    Quote Originally Posted by zombienerd View Post

    Be sure to use new Thermal paste on the CPU.
    The heat sink did not come off... I'm worried if the blow damaged the processor itself.

  7. #17
    Join Date
    Jan 2007
    Location
    Pacific Northwest, USA
    Posts
    25,032
    Blog Entries
    20

    Default

    Most any system will post part way with the Clock+SRAM chip removed. I suspect that you're battling something more significant. Have you tried the original chip?

  8. #18

    Default

    That's what I have been doing. That's why I'm afraid that I somehow broke my cpu...

    If I do have to replace the cpu do you think it would be a good idea to put a bit of a faster cpu in it? Like a 120mhz Pentium 1...
    Last edited by TravisHuckins; July 16th, 2017 at 11:07 PM.

  9. #19
    Join Date
    Jan 2007
    Location
    Pacific Northwest, USA
    Posts
    25,032
    Blog Entries
    20

    Default

    You might have also broken a support chip or even a trace on the PCB. Obviously, the latter can be repaired; the former, not as simple.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •