Image Map Image Map
Results 1 to 4 of 4

Thread: Toshiba flash codes

  1. #1

    Default Toshiba flash codes

    Hello again.

    I've got an old Toshiba Satellite t1920cs laptop and it wont boot. Gives me a flash code. Is anyone able to decipher it for me or point me to documentation? The unit flashes the power LED 2 times short, 1 time long, and 1 time short. Then repeats this over and over. Can't seem to find anything solid on Toshiba flash codes on the web, and there's no documentation left on this old laptop. Thanks!

  2. #2
    Join Date
    May 2006
    Location
    Melbourne, Australia
    Posts
    5,469

    Default

    The T1920 is between the T1900 and T1950. Both the T1900 maintenance manual and T1950 maintenance manual (at [here]) include, "If the DC IN indicator is flashing orange, the AC adapterís voltage supply is abnormal or the power supply is not functioning properly, go to Check 1." It sounds reasonable to assume that the T1920 maintenance manual would include the same.

    Someone recently posted about the symptom of a flashing power LED (although not orange) on a Toshiba notebook, and the cause was use of an incorrect power supply.

  3. #3

    Default

    Wow, hey, thanks for the link! Great!

    I did get it to boot!! Had to hotwire the battery to a 12v source and it loaded right into DOS and Win 3.1 no issues. So as the laptop was running off its own "battery", I plugged it into the AC cord and it immediately shut off flashing the orange battery light rapidly. Next I Measured the voltage output of the original power supply and its outputing exactly 15.08V. The T1910cs calls for 15V so I somehow doubt I have a power supply issue unless voltage drops off as current increases.

    I Did some research on the web and found two old articles that describe the problem I'm having as a bad capacitor on the power board. I've got one on order through Mouser and once replaced I'll let you guys know how I turn out. Thanks for the info!!

    Here's the Links to the faulty capacitor articles in case anyone needs them in the future.

    http://vobarian.com/toshibaProblem.html

    http://www.electronics.dit.ie/staff/...nd/tosh486fix/

  4. #4

    Default

    Well, capacitor replacement was a success! Now the laptop Boots perfectly! The old 6.3v 1000uf capacitor as shown in the links above on my unit was bulging. Replaced with a 16v 1000uf compliments mouser.com. Bought 2, just in case I messed one up. Shipping costed more than the capacitors. Anyhow, Barely got it to fit, but it did! Just before I went and buttoned it all back up, gave it a test run. All good except for a floppy drive issue now which I will start a new thread...

    Here's a few pictures. You can see the laptop all disassembled in the first pic. This one it not an easy machine to work on. Took me a while to figure it all out. Screws in random places, and random lengths, sizes... (nevermind the coors light). Next two pics show the bad capacitor and the new one installed, and last one is in Windows 3.1!

    IMG_2444.jpgIMG_2445.jpgIMG_2446.jpgIMG_2447.jpg

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •