Image Map Image Map
Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Oh FreHd, how thou hath thwarted me!

  1. #11
    Join Date
    Aug 2013
    Philadelphia,PA area


    Quote Originally Posted by Hans01 View Post

    If you want to solve the problem by yourself, there is a known problem with the BS170, this is what the manual says about it:
    2A. It turns out there are two different polarities for the BS170 (Q1) and the Fairchild product I used for the first 100 or so FreHDs is backwards which is why it is mounted reversed to the screen printing on the PCB. If you are building a FreHD from scratch and it gives flashing RED LED and otherwise won't work, try changing the polarity and see if that helps.
    There's another problem with Q1. As wired Q1 doesn't do anything useful. It's supposed to convert the 3.3V data from the SD Card to 5V. The gate of Q1 should be connected to 3V3 without a pullup resistor. Consult NXP Semiconductor's App Note AN10441 for details. You can also remove Q1 & R15 and jumper Q1's Source to Drain. See the attached photo. I did this on my FreHD and it works fine with my 4p. Q1-R15_mod.jpg Hope this helps.


  2. #12



    Sorry for the long delay. I actually posted awhile back, but I guess I forgot to submit it. I took Hans's advice and bought one of the TL866cs programmers, and my FreHD's now work! Wow, I thought I was losing my mind. I would highly recommend staying away from the VStager units. I think it was programming the PICs incorrectly. Interestingly, the TL866cs complained that the hex file for the FreHD was larger than the memory on the PIC, but it works anyway. Never saw that error on my other programmers. Whatever the case, I can finally move on.

    Thanks so much for everyone's help, and sorry for the delay in response. It took awhile for the new programmer to get here.

    Take care,

  3. #13


    I agree that it's probably not needed. Honestly, there are several changes I would propose making to the board, but all in all, they work fine as designed. I think the original version didn't have the FET, so there must have been a reason it was added down the road.

    As much as I've used them, I've never seen an error on a read or write.

    Thanks Tom, and take care,

  4. #14
    Join Date
    Dec 2010
    Frederick, MD


    Hello All:

    I can't believe I found this thread!

    So I've built my own FreHD for my TRS-80 Model 4, and am having trouble making it work.

    So here's my situation. I built it according to the schematics in the 2.14 release (schematics say date of 20-Apr-2013). In these schematics, it says use a PIC18F4610, so I tried that first, and nothing worked. I checked with Fred V. the designer, and he said it needed PIC18F4620, as the 4620 has EEPROM which is needed for the bootloader. So I get the 4620, and program it using firmware 2.13 via a PicKit3.

    I test power my FreHD, and it flashes D2 on power-up and also when I plug in an SD. According to my info, this is correct behavior.

    I have a TRS-80 Model 4, with U68 showing:

    TANDY c 80
    M 8341

    and Ian kindly verified I needed Model 4 NGA Gen1 ROMs for the autoboot ROM in U70. I didn't have any working 2716 EPROMS, so I doubled up the image onto a 2732 EPROM, programmed it with my Stager VS4000, and plugged it in.

    So I check my TRS80, and it seems perfectly normal after this ROM replacement. I can boot from a floppy, enter into BASIC, and type in a short program. I can boot into Model III mode and enter a program. I guess this proves the EPROM I burned is okay?

    So now I turn off, connect a home-made ribbon cable (with 50-pin card-edge connector to IDC, which I spot checked connectivity and seems good), turn on the FreHD (powered externally), install an SD (formatted FAT32, with frehd.rom, lsdos, ldos3, newdos3d, and cpm files on it, downloaded from Ian's website) and see the D2 LED flash once quickly.

    I turn on the TRS80 and it does not boot from the FreHD. I can use the TRS80 normally with the FreHD attached like this, and it's just like before the FreHD was connected. No flashing LEDs or anything on the FreHD during boot.

    So now I do a search, and find this thread about the BS170, and sure enough, I've got a Fairchild BS170. Does my scenario sound like the BS170 could be reversed in its polarity? I've wired it up according to the schematics (with the gate and source connected to SD pin 7, and the drain to PIC18F4620-pin 23).

    So I'm all about to reverse it, but wanted to check to see which was the best way to resolve this. The way I've wired my board, reversing the BS170 will be a pain, so I wanted some input before I underwent this. I also don't have a spare BS170 if I botch the job up. I guess if the reversal doesn't work, I can try without the BS170 as someone has suggested.

    Any suggestions before I give this a shot?

    Last edited by Holmes; February 11th, 2018 at 09:38 AM.

  5. #15
    Join Date
    Dec 2010
    Frederick, MD


    So I couldn't stand the wait, and I had some time this afternoon, so I went ahead and rewired my FreHD around the BS170.

    Guess what? It works now!

    Geez, I can't believe how much time I spent checking and rechecking my wiring - all because a part was manufactured "backwards"! I'm so glad I found this thread. It saved me!

  6. #16
    Join Date
    Mar 2016
    Pikesville, Maryland


    Ditto to contacting Ian
    Got to meet him personally at Tandy Assembly (photo is Trsbit magazine of the two of us) and he is AMAZING. He WILL get your boards working - GUARANTEED
    He has been a Godsend to me for the past few years

    Good luck


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts