Image Map Image Map
Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: K6-2 K6-III Linux build

  1. #1
    Join Date
    Jun 2011
    Location
    Newnan, GA USA
    Posts
    53
    Blog Entries
    2

    Default K6-2 K6-III Linux build

    Anyone do a Socket 7 K6-2 or K6-III Linux build back in the day? I'm doing a Socket 7 build to run Linux and would like to know what Linux version & core you used.

    My Socket 7 build:

    Asus P5-99VM, K6-2 500MHZ, 768 MB RAM, 120GB Hard drive. DVD, floppy. May upgrade it to a K6-III 450 MHZ.

  2. #2
    Join Date
    Jan 2007
    Location
    Pacific Northwest, USA
    Posts
    25,242
    Blog Entries
    20

    Default

    Back in the day? Like February? I occasionally run on a K6-2 450. Core? I assume you mean "kernel".

    Most all Linuces today use a Debian kernel--the only difference between them is what's bundled on.

    You didn't say what you wanted to do with the build--or if you needed a GUI. Later builds tend to be pokier on slow hardware, so you may want to look for a pre-systemd build, such as Squeeze. The choice of GUI will probably affect performance more than anything--I like XFCE because it's simple and reasonably fast.

    On my K6-2, I run non-GUI NetBSD 6.1.4 (which isn't Linux), which still has support for a number of legacy devices (which is why I use it), but your needs may be far different.

    The important thing is to have enough memory and disk storage available. 768MB should do for the first and perhaps 10GB for the second.

  3. #3

    Default

    Xubuntu 12.04 would run happily on my Thinkpad 390's meager Pentium MMX 233 + 512mb RAM, so I'm gonna imagine it would run on a K6-500mhz system even better. You might even be able to do some basic internet tasks through firefox on there. The thinkpad was used mostly for email and word processing by my kids. It was slow, but it worked.
    Current Vintage Equipment:
    IBM Thinkpad 390, IBM Aptiva A12, IBM PS/2 Model 25-004. Compaq Contura 4/25C.
    Asus P5A-B Socket 7 Box, Tandy 1000RLX-HD "B" & 1200-2FD, VIC20, Zenith ZFL-181-93, Packard Bell 300SX.
    Looking for: 286 Laptop, 386 Laptop, C64. Packard Bell Legend 20CD.

  4. #4
    Join Date
    Jun 2011
    Location
    Newnan, GA USA
    Posts
    53
    Blog Entries
    2

    Default

    Thanks all! Yes I did mean 'kernel" Sorry, my bad!

    The K6 will be used to compile a kernel & apps for my 233MHz Pentium Libretto 110CT that has only 64MB RAM. I have a modern Linux Mint computer with 8 GB RAM & Quad core but it's way to far from the Libretto to ensure compatibility with the Libretto. Hence the K6 as a stepping stone backwards to the Libretto.

  5. #5
    Join Date
    Jan 2010
    Location
    Central VA
    Posts
    3,415

    Default

    Sure, ran them back when they were current, and still have a few machines running them. Current Slackware and OpenBSD both run fine. I ran a bunch of different stuff on them when I was using them as my main systems -- Red Hat, Mandrake, SuSE, Slackware, Vector Linux (Slackware based), even Knoppix Live CDs. With 768 MB RAM installed you should have no problem with just installing a modern 32-bit distro.

    FYI, what you compile a kernel on has no bearing on the target's hardware, especially if they're both the same basic CPU architecture. For embedded stuff I just build from a 32-bit Slackware install on a VM, on my modern 64-bit workstation. You just have to set GCC flags to make sure you're not auto-picking the CPU optimizations based on the host system. NetBSD's cross compile system makes it even easier, if you want to go the NetBSD route -- you can build from any architecture, to any architecture. That's how you get modern NetBSD packages for stuff like Cobalt RaQs (150-250 MHz MIPS CPU) or old sun4m systems, without it taking ages.

  6. #6
    Join Date
    Jan 2007
    Location
    Pacific Northwest, USA
    Posts
    25,242
    Blog Entries
    20

    Default

    What glitch says is very true. I suspect that I can put together an x86 kernel on my Orange Pi PC running Armbian. I certainly compile ARM code on my x86 PC.

  7. #7
    Join Date
    Jan 2014
    Location
    Western North Carolina, USA
    Posts
    867

    Default

    Quote Originally Posted by aoresteen View Post
    Anyone do a Socket 7 K6-2 or K6-III Linux build back in the day? I'm doing a Socket 7 build to run Linux and would like to know what Linux version & core you used....
    I ran a server for a radio station for live streaming audio on a K6-II 400 in a VA-503+ motherboard that I just decommissioned a few months back; it had two hard drives in it that came from the previous server build (Super Micro dual Pentium Pro); one of the drives had run for twenty years (a 6GB Western Digital Caviar) and the other for 16-17 years (30GB Maxtor).

    OS of choice was Red Hat Linux 5.2 (NOT Red Hat Enterprise Linux 5; 1997-vintage Red Hat Linux 5.2, aka 'Apollo'). Red Hat was the only reasonably-priced supported OS for the Progressive Networks RealAudioServer, which was the standard of the day. I say reasonably-priced because I actually purchased the 'boxed set' for $49.

    I have run early CentOS on that age hardware; CentOS 6 I don't think will boot on i586-class hardware, but the K6-II was billed as i686 so it might. CentOS 4 (out of support) will boot on that age hardware. The only K6 I have in production right now is running Fedora Core 1:
    Code:
    [root@webcam3 root]# cat /etc/redhat-release
    Fedora Core release 1 (Yarrow)
    [root@webcam3 root]# cat /proc/cpuinfo
    processor	: 0
    vendor_id	: AuthenticAMD
    cpu family	: 5
    model		: 8
    model name	: AMD-K6(tm) 3D processor
    stepping	: 12
    cpu MHz		: 300.694
    cache size	: 64 KB
    fdiv_bug	: no
    hlt_bug		: no
    f00f_bug	: no
    coma_bug	: no
    fpu		: yes
    fpu_exception	: yes
    cpuid level	: 1
    wp		: yes
    flags		: fpu vme de pse tsc msr mce cx8 pge mmx syscall 3dnow k6_mtrr
    bogomips	: 599.65
    
    [root@webcam3 root]#
    The dmesg output:
    Code:
    Linux version 2.4.22-1.2129.nptl_24.rhfc1.at (bachbuilder@heretic.physik.fu-berlin.de) (gcc version 3.2.3 20030422 (Red Hat Linux 3.2.3-6)) #1 Fri Dec 12 20:11:09 EST 2003
    BIOS-provided physical RAM map:
     BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
     BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
     BIOS-e820: 00000000000f0800 - 0000000000100000 (reserved)
     BIOS-e820: 0000000000100000 - 0000000008000000 (usable)
     BIOS-e820: 00000000fffe0000 - 0000000100000000 (reserved)
    128MB LOWMEM available.
    ACPI: have wakeup address 0xc0001000
    On node 0 totalpages: 32768
    zone(0): 4096 pages.
    zone(1): 28672 pages.
    zone(2): 0 pages.
    DMI not present.
    ACPI: Unable to locate RSDP
    Kernel command line: ro root=LABEL=/ rhgb
    Initializing CPU#0
    Detected 300.694 MHz processor.
    Console: colour VGA+ 80x25
    Calibrating delay loop... 599.65 BogoMIPS
    Memory: 126120k/131072k available (1356k kernel code, 4564k reserved, 1076k data, 120k init, 0k highmem)
    Dentry cache hash table entries: 16384 (order: 5, 131072 bytes)
    Inode cache hash table entries: 8192 (order: 4, 65536 bytes)
    Mount cache hash table entries: 512 (order: 0, 4096 bytes)
    Buffer cache hash table entries: 8192 (order: 3, 32768 bytes)
    Page-cache hash table entries: 32768 (order: 5, 131072 bytes)
    CPU: L1 I Cache: 32K (32 bytes/line), D cache 32K (32 bytes/line)
    CPU:     After generic, caps: 008021bf 808029bf 00000000 00000002
    CPU:             Common caps: 008021bf 808029bf 00000000 00000002
    CPU: AMD-K6(tm) 3D processor stepping 0c
    Checking 'hlt' instruction... OK.
    POSIX conformance testing by UNIFIX
    mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
    mtrr: detected mtrr type: AMD K6
    ACPI: Subsystem revision 20031002
    ACPI: Interpreter disabled.
    PCI: PCI BIOS revision 2.10 entry at 0xfd8e9, last bus=2
    PCI: Using configuration type 1
    PCI: Probing PCI hardware
    PCI: Probing PCI hardware (bus 00)
    isapnp: Scanning for PnP cards...
    isapnp: No Plug & Play device found
    Linux NET4.0 for Linux 2.4
    Based upon Swansea University Computer Society NET3.039
    Initializing RT netlink socket
    apm: BIOS not found.
    Starting kswapd
    VFS: Disk quotas vdquot_6.5.1
    Detected PS/2 Mouse Port.
    pty: 512 Unix98 ptys configured
    Real Time Clock Driver v1.10e
    NET4: Frame Diverter 0.46
    RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
    Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    ALI15X3: IDE controller at PCI slot 00:10.0
    ALI15X3: chipset revision 193
    ALI15X3: not 100% native mode: will probe irqs later
        ide0: BM-DMA at 0xfcb0-0xfcb7, BIOS settings: hda:pio, hdb:pio
        ide1: BM-DMA at 0xfcb8-0xfcbf, BIOS settings: hdc:pio, hdd:pio
    hda: WDC WD136AA, ATA DISK drive
    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    blk: queue c03cca60, I/O limit 4095Mb (mask 0xffffffff)
    hdc: Hitachi CV 6.1.2, CFA DISK drive
    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    ide1 at 0x170-0x177,0x376 on irq 15
    hda: attached ide-disk driver.
    hda: host protected area => 1
    hda: 26564832 sectors (13601 MB) w/2048KiB Cache, CHS=1653/255/63, (U)DMA
    hdc: attached ide-disk driver.
    hdc: task_no_data_intr: status=0x51 { DriveReady SeekComplete Error }
    hdc: task_no_data_intr: error=0x04 { DriveStatusError }
    hdc: 15744 sectors (8 MB) w/1KiB Cache, CHS=246/2/32
    Partition check:
     hda: hda1 hda2 hda3
     hdc: hdc1 hdc2
    ide: late registration of driver.
    md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
    md: Autodetecting RAID arrays.
    md: autorun ...
    md: ... autorun DONE.
    Initializing Cryptographic API
    NET4: Linux TCP/IP 1.0 for NET4.0
    IP Protocols: ICMP, UDP, TCP, IGMP
    IP: routing cache hash table of 1024 buckets, 8Kbytes
    TCP: Hash tables configured (established 8192 bind 16384)
    Linux IP multicast router 0.06 plus PIM-SM
    NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
    RAMDISK: Compressed image found at block 0
    Freeing initrd memory: 158k freed
    VFS: Mounted root (ext2 filesystem).
    Journalled Block Device driver loaded
     hdc: hdc1 hdc2
     hdc: hdc1 hdc2
    EXT3-fs: INFO: recovery required on readonly filesystem.
    EXT3-fs: write access will be enabled during recovery.
    kjournald starting.  Commit interval 5 seconds
    EXT3-fs: recovery complete.
    EXT3-fs: mounted filesystem with ordered data mode.
    Freeing unused kernel memory: 120k freed
    usb.c: registered new driver usbdevfs
    usb.c: registered new driver hub
    PCI: Enabling device 00:14.0 (0000 -> 0002)
    PCI: No IRQ known for interrupt pin A of device 00:14.0. Please try using pci=biosirq.
    usb-ohci.c: found OHCI device with no IRQ assigned. check BIOS settings!
    usb.c: registered new driver hiddev
    usb.c: registered new driver hid
    hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
    hid-core.c: USB HID support drivers
    mice: PS/2 mouse device common for all mice
     hdc: hdc1 hdc2
     hdc: hdc1 hdc2
    EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,2), internal journal
    Adding Swap: 257032k swap-space (priority -1)
     hdc: hdc1 hdc2
     hdc: hdc1 hdc2
     hdc: hdc1 hdc2
     hdc: hdc1 hdc2
     hdc: hdc1 hdc2
     hdc: hdc1 hdc2
     hdc: hdc1 hdc2
    kjournald starting.  Commit interval 5 seconds
    EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,1), internal journal
    EXT3-fs: mounted filesystem with ordered data mode.
    ip_tables: (C) 2000-2002 Netfilter core team
    Intel(R) PRO/100 Network Driver - version 2.3.18-k1
    Copyright (c) 2003 Intel Corporation
    
    divert: allocating divert_blk for eth0
    e100: selftest OK.
    e100: eth0: Intel(R) PRO/100 Network Connection
      Hardware receive checksums enabled
      cpu cycle saver enabled
    
    8139too Fast Ethernet driver 0.9.26
    divert: allocating divert_blk for eth1
    eth1: SMC1211TX EZCard 10/100 (RealTek RTL8139) at 0xc8887c00, 00:e0:29:6f:19:92, IRQ 10
    eth1:  Identified 8139 chip type 'RTL-8139B'
    ip_tables: (C) 2000-2002 Netfilter core team
    eth1: link up, 100Mbps, full-duplex, lpa 0x41E1
     hdc: hdc1 hdc2
     hdc: hdc1 hdc2
    Linux video capture interface: v1.00
    i2c-core.o: i2c core module version 2.8.1 (20031005)
    bttv: driver version 0.9.11 loaded
    bttv: using 8 buffers with 2080k (520 pages) each for capture
    bttv: Host bridge is ALi Corporation M1541
    bttv: Bt8xx card found (0).
    bttv0: Bt878 (rev 17) at 02:00.0, irq: 11, latency: 132, mmio: 0xfdfff000
    bttv0: using: BT878(LMLBT4) [card=110,insmod option]
    LMLBT4x init
    bttv0: using tuner=0
    bttv0: registered device video0
    bttv0: registered device vbi0
    bttv0: PLL: 28636363 => 35468950 .. ok
    bttv: Bt8xx card found (1).
    bttv1: Bt878 (rev 17) at 02:01.0, irq: 11, latency: 132, mmio: 0xfdffd000
    bttv1: using: BT878(LMLBT4) [card=110,insmod option]
    LMLBT4x init
    bttv1: using tuner=0
    bttv1: registered device video1
    bttv1: registered device vbi1
    bttv: Bt8xx card found (2).
    bttv2: Bt878 (rev 17) at 02:02.0, irq: 11, latency: 132, mmio: 0xfdffb000
    bttv2: using: BT878(LMLBT4) [card=110,insmod option]
    LMLBT4x init
    bttv2: using tuner=0
    bttv2: registered device video2
    bttv2: registered device vbi2
    bttv: Bt8xx card found (3).
    bttv3: Bt878 (rev 17) at 02:03.0, irq: 11, latency: 132, mmio: 0xfdff9000
    bttv3: using: BT878(LMLBT4) [card=110,insmod option]
    LMLBT4x init
    bttv3: using tuner=0
    bttv3: registered device video3
    bttv3: registered device vbi3
    bttv0: PLL can sleep, using XTAL (28636363).
    spurious 8259A interrupt: IRQ7.
    [root@webcam3 root]#
    It's a webcam capture machine with one of the Linux Media Labs four-channel BT878 cards in it, and it still does the job it was installed to do back in January of 2004. Yeah, it's been running continuously since 2004, rebooted nightly (BT878 card lockups if let run more than a few days, easier to reboot nightly).

    Uptime information:
    Code:
    [root@webcam3 root]# date                                       
    Mon Oct  9 19:20:09 EDT 2017
    [root@webcam3 root]# uptime
     19:20:10  up 21:44,  1 user,  load average: 0.10, 0.10, 0.03
    [root@webcam3 root]#
    Last edited by lowen; October 9th, 2017 at 04:20 PM.
    --
    Bughlt: Sckmud
    Shut her down Scotty, she's sucking mud again!

  8. #8
    Join Date
    Jan 2007
    Location
    Pacific Northwest, USA
    Posts
    25,242
    Blog Entries
    20

    Default

    I recall that K6 is missing a critical instruction for later Linux releases. To wit:

    The following processors, supported in jessie, are now unspported:

    * AMD K5, K6, K6-2 (aka K6 3D), K6-3
    * DM&P/SiS Vortex86, Vortex86SX
    * Cyrix III, MediaGX, MediaGXm
    * IDT Winchip C6, Winchip 2
    * Intel Pentium, Pentium with MMX
    * Rise mP6
    * VIA C3 'Samuel 2', C3 'Ezra'
    I don't know if you can re-build the kernel to support pre-PII CPUs. So use something earlier than the "Jessie" kernel or use OpenBSD or NetBSD. Maybe FreeBSD--I haven't tried it.

  9. #9
    Join Date
    Jan 2010
    Location
    Central VA
    Posts
    3,415

    Default

    So basically Jessie is now i686 only?

    Slackware 32-bit still supports down to i486, and will in fact boot on a 486.

  10. #10
    Join Date
    Jan 2010
    Location
    New Zealand
    Posts
    3,384
    Blog Entries
    4

    Default

    I'm a quite a fan of Xandros 2.0 Linux with extra repositories added to install some extra applications. I have it running on my P1 200mmx machine. Its quite a reasonably small install of about 500megs depending on the options you choose. Picked up the network card and had correct video drivers. I replaced Red Hat 7.3 with it due to its better usb support.
    Thomas Byers (DRI)- "You'll have a million people using the A> [MS-DOS prompt] forever. You'll have five million using [nongraphic] menu systems such as Topview, Concurrent PC-DOS, Desq, and those types. But there'll be 50 to 100 million using the iconic-based interfaces."

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •