Image Map Image Map
Results 1 to 4 of 4

Thread: Floppy Drive Problem

  1. #1

    Default Floppy Drive Problem

    Hello again!!

    Toshiba T1910cs 486 laptop..

    turn it on and it will self test the floppy as it boots. Once in DOS with no disc in the drive, type A:\ and enter it will check the drive and you can hear a "normal" sound. Once you put a disc in the drive, it sounds as though a motor starts spinning full steam ahead and wont stop until the disc is removed. Doesn't matter one bit if DOS is accessing the drive or not, or even if the machine has fully booted yet. Anytime its turned on and there is a disc in the drive, it will spin up. Also it will not read the disc, nothing but "abort, retry, fail," error.

    How do these old drives work, like am I able to take it apart, is there a belt or something inside that could have worn out?

    Thanks!!

  2. #2

    Default

    In reading, there is a belt in these drives. I ordered an assortment of drive belts off flea-bay for less than $2.00 shipped. I supposed its worth the gamble that there is one included that will be the correct size.

    So, how do you remove the floppy drive out of this laptop? I've had it all apart and couldn't figure out how to remove it. This is not an easy machine to work on by any means, but I just must be missing a screw someplace or something.

  3. #3
    Join Date
    May 2006
    Location
    Melbourne, Australia
    Posts
    5,472

    Default

    Quote Originally Posted by tblake05 View Post
    So, how do you remove the floppy drive out of this laptop? I've had it all apart and couldn't figure out how to remove it. This is not an easy machine to work on by any means, but I just must be missing a screw someplace or something.
    There are maintenance manuals for the T1900 and T1950 at [here]. Those models may be similar enough to the T1910 that their replacement procedures are usable for the T1910.

  4. #4

    Default

    It indeed was a bad belt inside the floppy drive. I ordered a replacement pack for a little over $1.50 shipped off ebay straight from China. Let me tell you, when they say delivery will be about a month away, they are not joking. Nonetheless, the pack came and the closest belt I found included was a little narrower but it worked just fine. Tough to get inside and all lined up but all went well. Lubed the rails and cleaned the heads while I was in there too.

    IMG_2477.jpg

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •