Image Map Image Map
Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: HxC and Model II/16

  1. #1

    Default HxC and Model II/16

    I have a Model II and am trying to use an HxC SD floppy emulator with it using one of Mark's fd50to34 adapter cards.

    I was able to boot from the TRSDOS 2.0 and all the CP/M images (except for CP/M Plus) from the Model II archive. I couldn't use the HxC as both drives 0 and 1 since the Model II controller only supports one internal drive (thanks to that reminder from Mark). I swapped in the floppy controller from my deal Model 16 and was then able to use the HxC as drives 0 and 1. I tried to install from the P&T CP/M image which wants to format and install a working copy on the disk in drive B. I copied the boot image and tried to use the copy for the disk in drive B but it formats up to track 43 and then fails on track 44. I'm guessing this is related to the TG43 signal but I've not used many systems with 8" floppy drives in the past.

    Is anyone using an HxC with Mark's adapter on a Model II/12/16? If so, is there any trick to the jumper settings on Mark's adapter or the setting for the HxC?

  2. #2

    Default

    I have a Model II that behaves the same way. It won't write past track 43 with HxC or real floppy. I have not yet looked into it further as I have another Model II without the issue. Both have the later M16 FDC card. Have you tried with a real floppy?

  3. #3

    Default

    I haven't tried formatting a real floppy. I need to make a new cable so I can have the HxC and floppy drive connected at the same time.

  4. #4

    Default

    Quote Originally Posted by Alphasite View Post
    I couldn't use the HxC as both drives 0 and 1 since the Model II controller only supports one internal drive (thanks to that reminder from Mark).
    I was testing some newly acquired Model II cards today and one of them happened to be the early floppy controller or FDC board. Remembering this thread, I decided to test it with my HxC and it actually does work very well using both drives on the HxC. I suspect your floppy controller needs some adjusting or repair.

    BTW, I have never had much luck formatting Model II disks with the HxC. I have to look into this further.

  5. #5

    Default

    I can read and write okay with both floppy controllers. It was formatting that was failing, so if that's not working for you as well then maybe I'm okay.

    I tried connecting up my external drive bay and it's not working. The power LED doesn't come on and the Model II won't boot with it connected so I'll need to open it up and look after I get over this cold.

    I do have an issue where I can't boot the CP/M Plus, TRSDOS-II 4.2, or Model 16 Systems disk (if I install my 68000 CPU and memory) images. That may be something else.

  6. #6
    Join Date
    Jun 2013
    Location
    Sydney, OZ
    Posts
    123

    Default

    Quote Originally Posted by pski View Post

    BTW, I have never had much luck formatting Model II disks with the HxC. I have to look into this further.
    CPM "seems" to format OK on the Model II with the HxC but I could not get LSDOS or TRSDOS to format.
    Same goes when formatting the HxC on the System80. TRSDOS aborts with a motor fast error and NEWDOS aborts with a motor slow error.
    I patched TRSDOS to format OK and EVAD did some excellent detective work via the CRO and got NEWDOS to format OK.

    Off the top if my head I can't remember the exact details but I think the HxC is a bit slack on the timing of it's index pulse.
    Formats a complete track and then decides it might be a good idea to send an index pulse.

  7. #7

    Default

    When I try under CP/M format seems to work until it hits track 44, then fails.

    Which version of the HxC do you have?

  8. #8

    Default

    I doubt the HxC does anything useful with the track 43 signal. You might try just disconnecting it
    from the cable. Activity on that line might be causing issue in the emulator. Since it is not a real disk,
    it should ignore the signal from the controller. It may be that it is just doing something wrong. Since it
    is working on the lower tracks, disconnecting the signal might be a good idea.
    On a real disk it would change the write current. I can't imagine what a emulator would do with it.
    For double density, some controllers also change precomp. That may cause issues for the HxC.
    I'd not considered that as a possible issue.
    Dwight
    Last edited by Dwight Elvey; November 19th, 2017 at 10:30 AM.

  9. #9

    Default

    There's a jumper on the fd50to34 board. I've tried changing it without luck.

    There are two or three different versions of the HxC as well as Gotek emulators with HxC firmware. It would be interesting to see which version people have and whether or not they can format.

  10. #10
    Join Date
    Feb 2014
    Location
    Netherlands
    Posts
    369

    Default

    @Alphasite

    I think you are using a 'Late Design' Floppydisk Controller, item number: 8709198 in your Model II
    In that case you have to rewire the flat cables.
    At first you have to open the holes on the PCB for the 50 pin header, just below the 50 finger edge connector.
    You have to solder a 50 pin header in these 50 pin holes.
    Then you must connect the internal disk drive and the external floppy connector to this header.
    In this situation you can use 2 drives on this connection.
    If you want to connect more drives you have to connect them to the 50 finger edge connector on the FDC adapter
    You have to set the jumpers on this adapter according this jumper table.
    I hope this solve your connection problem.

    FDC-Late.jpg

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •