Image Map Image Map
Results 1 to 7 of 7

Thread: ?setup XTIDE v4 in Amiga 2000 w8086 card

  1. #1

    Default ?setup XTIDE v4 in Amiga 2000 w8086 card

    I've added an XTIDE rev 4 card to an Amiga 2K, but have no idea what to set all 16 dip switches to for this config, and Google has failed me. Is there any guidance you can give? What I've found so far is that the ROM address is fine at the default of D000, but I've no idea what IRQ to use, and the XTIDE came with no instructions. Searching turns up mostly results for rev two of the board, and almost nothing for rev 4.

  2. #2
    Join Date
    Apr 2010
    Location
    Albany, OR USA
    Posts
    692
    Blog Entries
    1

  3. #3

    Default

    Thanks for that, i gather from this that the rev 3 instructions and rev 4 boards are essentially the same, Glitchworks could probably update their instructions to reflect this and save some confusion.

  4. #4

    Default

    Now I'm wondering whether the rom included with the Glitchwork kit was programmed. Is there a message visible on start-up?

  5. #5
    Join Date
    Jan 2010
    Location
    Central VA
    Posts
    3,411

    Default

    Hi there Working on the manual, life's busy at the moment.

    If you bought the parts kit, the EEPROM is not programmed. If you bought a fully assembled+tested board, then it is programmed. The card can self-program using the XT-IDE Universal BIOS configuration program.

  6. #6

    Default

    Quote Originally Posted by glitch View Post
    EEPROM is not programmed.
    Since I can't seem to boot the Amiga from the floppy drive (or, actually, it is a Gotek 720KB version drive), in order to program the EEPROM, is it instead possible to replace the EEPROM with a simple swap using a 27c64 pre-programmed with the rom?

    I can read from the Gotek, just not boot, so I will perhaps be able to setup the compact flash in a 90's ms-dos rig once the XTIDE is running.

  7. #7
    Join Date
    Jan 2010
    Location
    Central VA
    Posts
    3,411

    Default

    Yeah, a 2764 or 27256 will work fine. Make sure that the ROM image has the proper checksum generated at the end of it. The BIN files you download for the XUB are unconfigured and do not have the checksum (the configuration tool generates it). If you run into a hard time with the checksum, let me know and I can dump a configured ROM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •