Image Map Image Map
Results 1 to 6 of 6

Thread: PET 2001-8 Booting Problem

  1. #1

    Default PET 2001-8 Booting Problem

    I have a PET 2001-8 that will not boot. I tested the RAM using the instructions from Dasaro Designs (http://www.dasarodesigns.com/project...dore-pet-2001/) and removed 2 faulty RAM chips. It still wouldn't boot. I bought a ROM/RAM replacement board from Tynemouth Software (http://blog.tynemouthsoftware.co.uk/...nt-boards.html), set it to replace all RAM and all ROM and use BASIC 1.0. Still wouldn't boot. I set the replacement board to use the PET Tester program (Which is meant to alternate between character set and RAM check, but only the bottom line of the display changed. It alternated between last line of the character set and all Gs meaning good RAM). The rest of the display continued to display random characters. I am at a loss as to what could be the issue. The video RAM appears to be ok, as the characters are random, and I believed that the video ROM was ok as the characters were displayed clearly with no noise or corruption. Does anybody have any idea what the problem could be and how to test it further/fix the issues?

  2. #2
    Join Date
    Oct 2017
    Location
    SE Michigan, USA
    Posts
    574

    Default

    Check the Character ROM for issues (overheating, low voltage, cracked or cold solder points, and so on).

  3. #3
    Join Date
    Jun 2012
    Location
    UK - Worcester
    Posts
    3,790

    Default

    Can you post some photographs or a video somewhere so we can have a look?

    Dave

  4. #4

    Default

    I Agree with Dave.. if you could post a photo that would be very useful.

    You could still have a bad BASIC ROM that prevents the system from booting properly with the rom/ram board.

    Have you removed the basic rom chips and also the big chips PIA and VIA to see what happens ?

    When you boot the PET does it show the garbage screen permanently or does it clear to a blank screen ?

    Andy
    Last edited by AndyG; March 28th, 2018 at 11:18 PM.

  5. #5
    Join Date
    Jan 2012
    Location
    Connecticut, USA
    Posts
    2,714

    Default

    So what happened with this? Did you fix the PET 2001-8?

  6. #6
    Join Date
    Oct 2017
    Location
    SE Michigan, USA
    Posts
    574

    Default

    The OP's new posts aren't showing since this site requires moderation up to 10 posts, then, every other post after post #10 will show up automatically.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •