Image Map Image Map
Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: Windows 2.x hangs on splash screen

  1. #21

    Default

    A TSR wouldn't help, because Windows drivers only use the BIOS to select a video mode - after that, they operate directly on the hardware.

    The PC1512 is a four-plane extension of CGA, giving 16 colours at 640x200 resolution. Unlike an EGA, it doesn't have any registers allowing accelerated reads / writes of the plane memory, nor does it have the EGA's programmable palette. With an original driver source tree, it might just be a matter of changing a few EQUates and kicking off the build process (that was pretty much all I had to do when building the PC1512 driver for GEM) but with no source, or even disassembled source, it's not straightforward at all.

    As mentioned upthread, there's a Binary Adaptation Kit for Windows 2.x, but I'm not aware of anything similar for Windows 1.x having come to light. With this, a disassembler, and a lot of patience, it's possible to create source trees that build to Windows 1.x drivers, but the actual code is all disassembled so you don't have the names of local variables and so on.

  2. #22
    Join Date
    Feb 2017
    Location
    Guildford, U.K.
    Posts
    468
    Blog Entries
    1

    Default

    I could assist with disassembly. I have the V-Communications Sourcer, BIOS preprocessor v8.01, which copes with various ROMs, executable file formats, VxDs, DLLs, Windows 386+ and OS/2 stuff. As you say though, it can be a long repetitive process to get to a source tree.

  3. #23

    Default

    Quote Originally Posted by krebizfan View Post
    If the video card is well documented and similar to a standard card, it should be possible to get a working driver in a reasonable amount of time. Otherwise, well, I found writing real mode Windows drivers an exercise in frustration. You may have better luck.
    I was thinking about my Philips :YES. Its video hardware is about as capable as CGA, but completely incompatible (there is no dedicated VRAM; the BIOS reduces conventional memory by 57 KB if a graphics mode is selected). The machine itself is based on an 80186, without any PC chipset compatibility (no PIC, PIT, DMAC, KBC, UART, ...). So Windows would definitely require a lot of adaptations, if it is possible at all. Thanks for your insight, though. It would definitely be a long-term project for me.

  4. #24

    Default

    The other consideration is copyright. GEM was open-sourced, so I didn't feel any particular compunction about disassembling binary files and basing drivers on them (as long as the copyright message said they were written by Digital Research and not, eg, Trident or ATI). But Microsoft haven't open-sourced Windows 1.x, so distributing anything derived from the existing Windows 1.x drivers could potentially bring forth the wrath of their legal department.

  5. #25
    Join Date
    Feb 2018
    Location
    Bristol, UK
    Posts
    227

    Default

    Quote Originally Posted by cobalt2035 View Post
    I am having the exact same problem with my PC1512 (upgraded to 640KB and NEC V30). I have tried both DOS 3.2 and 5.0 with SETVER. Windows 2.03 freezes on the splash screen.

    However, Windows 1.04 runs fine, even with the Amstrad mouse (got the driver from the Amstrad OEM 2.03 distribution 'MOUSE2.DRV').

    Thanks!
    I did have some success on my IBM 5150 loading Windows 2 from a ZIP disk, but exactly the same files would fail when loading from any other source, and they still wouldn't load on the Amstrad. I've drawn the conclusion that it has to be down to some obscure timing issue making the CGA driver fall over when initialising (it freezes at exactly the point that the splash screen should disappear and the desktop background should load).

    Either way, Windows 3.0 always worked perfectly (although it is 4 times bigger than Windows 2 and looks particularly bad in CGA).

    It's odd you still have the problem with a V30 fitted though. As soon as I swapped out the 8088 for a V20 in my IBM 5150 this cured all the problems and it now loads Windows 1/2 fine without any issues at all.

  6. #26

    Default

    If indeed Microsoft did make a prototype Windows 1.x driver for the PC1512 for internal use at Amstrad, wouldn't it be great to get hold of it and try it? I have tried to get in touch with Mr Lawson about this to no avail, unfortunately...

  7. #27
    Join Date
    Feb 2018
    Location
    Bristol, UK
    Posts
    227

    Default

    Quote Originally Posted by cobalt2035 View Post
    If indeed Microsoft did make a prototype Windows 1.x driver for the PC1512 for internal use at Amstrad, wouldn't it be great to get hold of it and try it? I have tried to get in touch with Mr Lawson about this to no avail, unfortunately...
    I am surprised that there was never a 640x200x16 PC1512 driver for Windows made. In the early days Microsoft seemed glad to provide extra support to anyone who wanted get behind Windows and help give it some traction. Hence they were happy to provide developers with free runtime versions to bundle with early Windows applications to help sales, and within the UK Microsoft produced RM Nimbus ports of Windows 1/2/3.0 for it's oddball 640x250 4 colour graphics and flat memory architecture giving up to 1MB RAM in real mode. Even though GEM was pushed on the 1512/1640, when Amstrad quickly appeared to favour Windows bundling it with many machines from the PC 2000 series onwards I'm surprised Microsoft didn't offer a PC1512 video driver in order that Amstrad could push a Windows package to sell back to owners of the earlier machines in place of GEM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •