Image Map Image Map
Results 1 to 4 of 4

Thread: Tandy 2500 SX/33 CF IDE adapter woes

  1. #1

    Default Tandy 2500 SX/33 CF IDE adapter woes

    I bought a Tandy 2500 SX/33 (I had a 2500 SX/25 when I was 12, so this was the closest thing). Unfortunately, it has been nothing but problems since. Starting with the VGA cable. The 2500 has a 14 pin VGA interface that I couldn't plug a normal cable into, so I ordered a 14 pin one from Amazon that came with 15 pins. After that debacle i pulled the extra pin from another cable and that is sorted.

    Then I started having HDD issues. It had two hard drives, a 207 MB WD Caviar 1210 primary (C drive and a 108 MB Seagate ST3120 secondary drive (D. I was able to back up the Seagate and it was still working fine, but the WD kept getting worse and worse and now it is pretty much dead (it did work pretty much fine, maybe with a few bad files when I got it, though it passed scandisk with flying colors). I'm pretty bummed I missed my window of opportunity on the WD drive, because it was a fantastic snapshot of early to mid 90s computing.

    I have gotten two separate CF to IDE adapters and neither of them really work, the first adapter I tried mostly with a 16 GB card and it would sort of show up in fdisk and I could change drives to it, and issue the DIR command, but it wouldn't actually read or write any files to it. I created 512 MB partition in gparted on linux, because I didn't want to confuse DOS fdisk with a 16G disk.

    Then I got the other adapter with a 512 MB CF, which should definitely be below any BIOS / IDE-1 limits, but it wont cooperate either. When I try to install MS-DOS 6.22, there is an error reading COMMAND.COM at the end of the install and when I reboot it just says there is a drive read error. The files from the install appear to be on the drive, but when I issue the DIR command it lists the files, but stopped before listing the free space. I have pictures of these errors if that would help. I've also tried FREEDOS with no improvement (I can't remember if the install had any problems, but it did complete).



    I have the adapter models I used in this reddit post.
    adapter 1 (PROCONN): https://www.ebay.com/itm/40Pin-ATA-I...72.m2749.l2649

    adapter 2 : https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

    Here are my CF cards:
    512MB: https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

    16GB: https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

    At this point I think I've tried both adapters with both CF cards (and new IDE cables) along with MS-DOS 6.22 and FREEDOS 1.2 on both. I'm kind of stumped and the computer is sitting on my desk, all taken apart and sad. I would really like to get some hot DOS and WFWG 3.11 action going, but no luck so far. Do you all have any advice?


    D.jpgC.jpgB.jpgA.jpg

  2. #2

    Default

    What I wound up doing is this:

    1) Got a Ethernet board that supports a ROM and flashed the XDIDE BIOS on it. This allowed me to then use larger IDE drives. You can do this with any 8 bit ISA adapter that has a ROM socket.
    2) Got a 1GB Disk On Chip from eBay. Note, I had to get a female-female IDE dongle to put this on the hard drive cable, or you can plug it in by itself on the IDE channel on the motherboard.
    3) FDISK and Format the DoC with MSDOS 6.22.

    I can dig it out and grab all the part numbers I used, but that was the easiest way for me to setup everything.

    The 2500 SX/33 and the 4825 I both have XTIDE BIOS on as well as the Disk On Chip. I forgot what I left the BIOS settings for the drive. The 4825 actually has an IDE CDROM (Lite-On) and a Disk On Chip installed on the motherboard IDE connector. On the 2500, I might have just plugged the Disk On Chip into the IDE slot on the motherboard and not used the second IDE connection.

    I also have a 1000 RLX-B that uses an XT-IDE interface (not to be confused with the BIOS or the XT-IDE card), which that trick doesn't work on due to the IDE controller supporting only those XT type IDE hard drives.

  3. Default

    I would really appreciate part numbers of stuff. For #1, you used a ethernet board to load IDE BIOS? How does that work? What is the system limited to if you don't have another BIOS, 512MB? These are some good ideas. I had really hoped to use the CF to allow easy swapping, but I guess I'll take what I can get.

  4. Default

    I found on this page that my Etherlink III supports a DIL28 PROM, would that work?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •