Image Map Image Map
Page 6 of 6 FirstFirst ... 23456
Results 51 to 57 of 57

Thread: TRS-80 Model 12 successfully shipped

  1. #51

    Default

    Quote Originally Posted by Alphasite View Post
    The TRSDOS-II format failed. It may be a heat issue. I need to get a better fan to cool the ST251-1 drive.

    In the meantime I pulled out the Gesswein emulator first because it had edge connectors so I wouldn't have to swap cables. I was able to format an emulated ST251 from the diags and read back all the tracks. TRSDOS-II formatted as well but failed initializing the directory after format. Aton CP/M formatted but there were errors on some of the tracks (which shouldn't be the case). It wouldn't boot after the format and system copy was complete and I couldn't access the hard drive booted from the emulated floppy. Radio Shack CP/M Plus was able to format and copy over the system tracks and I was able to copy all the files over and it booted just fine. No errors at all.

    After that I tried the DREM and had no luck. Formatting from the diags failed (errors on the DREM console for every track and head) so I turned on logging and tried formatting again. I got an empty log file so I need to investigate that.
    Are you on a Type 2 with an 8x300 or still using the type 4? Heat can cause the drive controller to go out of "alignment". Happened to me this weekend. Just a tad out off that drifted enough. It has the ceramic capacitor though.

  2. #52

    Default

    I'm using the type 4.

  3. #53

    Default

    Quote Originally Posted by Alphasite View Post
    I'm using the type 4.
    Ok ignore me on that one. I have never seen the WD based ones have heat issues. Come to think of it, I'ver never had any issues with them. I guess thats why people like them more.

  4. #54

    Default

    I was able to get the type 4 to work with the Gesswein with the diags and CP/M Plus without letting it cool so I think it's the drive.

    There's a recent update to the Gesswein code so I'm going to try that this weekend. I also will reload the DREM SD card. I was unable to get it to write any diags so I want to see if it's corrupted.

  5. #55

    Default

    Thanks to Pete I have the DREM working and have even booted Xenix 3.2.0. I built a new SD card image for the DREM.

    The updated code for the Gesswein emulator didn't help with TRSDOS-II (diags and CP/M work). After TRSDOS-II finishes the format the Gesswein dumps a bunch of hex and exits the emulation so I need to send the log file to David Gesswein. Hopefully it's a bug in his emulator that can be fixed and not some incompatibility. It would be nice to have both the DREM and Gesswein emulators working.

  6. #56

    Default

    TRSDOS-II had an error trying to write the disk ID and directory information after the format with the DREM as well ("ERROR 8").

    The DREM also didn't work with Aton CP/M. After a few tracks I'd get an odd message on the display connected to the DREM and it would hang. I'll need to turn on logging to collect data to send.
    CP/M Plus also failed. I got complaints from the DREM that the side wasn't a power of 2 (the DREM calls heads sides) which is odd since it didn't have any problem with 5 heads with Xenix.

  7. #57

    Default

    A combination of the Gesswein emulator and a type 4 controller with the latest update worked for me. I now have Xenix 3.2.0 running.

    Many thanks to Pete for all his help.

    I was also able to install and boot P&T CP/M from the hard drive.

    Next up, get the log files to David to see why TRSDOS-II kills the emulation software.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •