Image Map Image Map
Page 6 of 6 FirstFirst ... 23456
Results 51 to 53 of 53

Thread: Dec RK8E controller for RK05 wanted

  1. #51


    Quote Originally Posted by Roland Huisman View Post
    In the meanwhile Jack Rubin did help me a lot to get GTTY running again on a modern PC.
    And Lou helped me a lot with his H803 which I turned into H851s

    So my Plessey RK8E clone now has brand new H851 blocks on it:
    Attachment 48652

    Time to test...

    Well I've tried to test the Plessey controller which was bought incomplete. So it was in unknown state.
    I ran on the service image within OS8. And immediately I got:

    If I pulled out the controller I got a slightly different message.
    So it seems to detect the board but it quits almost immediately as well.

    To be sure I wanted to toggle in the rimloader, load the binloader and run the
    test from a papertape image which I downloaded from Vince his website.

    After toggeling in the RIM loader somehow I made an error myself and gave
    the start address of 7777 instead of the 7756. Suddenly text like this showed up.

    Now that is weird! I haven't loaded any papertape image yet. This was still in core.
    Within a few seconds this message showed up in the disk server:

    Probably the code ran into a part of OS8 in core, no idea what happend...

    Next try went better... Rim loader, bin loader and loaded dhrka-e.bin
    After starting the test the system ran for about four minutes and then:

    WooHoo! So don't run tests within OS8 disk server... This might fail...

    Attachment 48653 Attachment 48654 Attachment 48655 Attachment 48656

    The postman from China is letting me down a bit. I'm waiting for three weeks now on the M993 PCB's.
    At this point I can't get any further... I hope the boards are coming soon...
    I tested my RK8E controller this weekend. First I started the DHRKAE.DG from;sort=name using OS/ and serial disk. It failed, but not directly. So I tried the version on Vince site and it failed in the exakt same way! I compared the binaries, they should be the same maindec version but they differ. I guess that the one that I used on OS/8 contains a terminal package.

    PC:2253 GD:2202 ST:2200
    DHRKAE FAILED PC:6726 AC:0000 MQ:7777 FL:0000
    I guess I have some trouble shooting to do. I ran the test with no disk attached (since I'm missing the cabling).

  2. #52


    I've tested my controller with the paper tapes from Vince and loaded them
    trough the RIM/BIN loader. That worked just fine.
    But using OS8 and the disk server gave problems with these test programs.
    Last edited by Roland Huisman; January 17th, 2019 at 05:02 AM.
    WTB: Dec TU56 / Case for Altair 8800 ...... Rolands Github projects

  3. #53


    Well, I got the same result even if I ran the paper tape from Vince site. I loaded it with the binary loader, but I started BIN-loader from OS/8 using "BOOT/PT". "BOOT/PT" places the binary loader in memory and halts. Then you use it as usual. I guess its the same as toggle in RIM-loader and then load the BIN-loader or?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts