Image Map Image Map
Page 6 of 7 FirstFirst ... 234567 LastLast
Results 51 to 60 of 63

Thread: Dec RK8E controller for RK05 wanted

  1. #51

    Default

    Quote Originally Posted by Roland Huisman View Post
    In the meanwhile Jack Rubin did help me a lot to get GTTY running again on a modern PC.
    And Lou helped me a lot with his H803 which I turned into H851s

    So my Plessey RK8E clone now has brand new H851 blocks on it:
    Attachment 48652

    Time to test...



    Well I've tried to test the Plessey controller which was bought incomplete. So it was in unknown state.
    I ran dhrkae.sv on the service image within OS8. And immediately I got:



    If I pulled out the controller I got a slightly different message.
    So it seems to detect the board but it quits almost immediately as well.

    To be sure I wanted to toggle in the rimloader, load the binloader and run the
    test from a papertape image which I downloaded from Vince his website.

    After toggeling in the RIM loader somehow I made an error myself and gave
    the start address of 7777 instead of the 7756. Suddenly text like this showed up.


    Now that is weird! I haven't loaded any papertape image yet. This was still in core.
    Within a few seconds this message showed up in the disk server:


    Probably the code ran into a part of OS8 in core, no idea what happend...

    Next try went better... Rim loader, bin loader and loaded dhrka-e.bin
    After starting the test the system ran for about four minutes and then:


    WooHoo! So don't run tests within OS8 disk server... This might fail...

    Attachment 48653 Attachment 48654 Attachment 48655 Attachment 48656

    The postman from China is letting me down a bit. I'm waiting for three weeks now on the M993 PCB's.
    At this point I can't get any further... I hope the boards are coming soon...
    I tested my RK8E controller this weekend. First I started the DHRKAE.DG from http://www.pdp8.net/pdp8cgi/os8_html...rk05;sort=name using OS/ and serial disk. It failed, but not directly. So I tried the version on Vince site and it failed in the exakt same way! I compared the binaries, they should be the same maindec version but they differ. I guess that the one that I used on OS/8 contains a terminal package.

    Code:
    STATUS REGISTER ERROR
    PC:2253 GD:2202 ST:2200
    DHRKAE FAILED PC:6726 AC:0000 MQ:7777 FL:0000
    I guess I have some trouble shooting to do. I ran the test with no disk attached (since I'm missing the cabling).

  2. #52

    Default

    I've tested my controller with the paper tapes from Vince and loaded them
    trough the RIM/BIN loader. That worked just fine.
    But using OS8 and the disk server gave problems with these test programs.
    Last edited by Roland Huisman; January 17th, 2019 at 04:02 AM.
    WTB: Case for Altair 8800 ...... Rolands Github projects

  3. #53

    Default

    Well, I got the same result even if I ran the paper tape from Vince site. I loaded it with the binary loader, but I started BIN-loader from OS/8 using "BOOT/PT". "BOOT/PT" places the binary loader in memory and halts. Then you use it as usual. I guess its the same as toggle in RIM-loader and then load the BIN-loader or?

  4. #54

    Default

    I have struggled with my board set again after some break. Other thing came in between. I have no luck to get the boards to pass the MAINDECS.

    Roland, or someone else with a known good controller, can you execute the following program and see what the AC contains at the last line before the JMP? The controller should not be connected to the drive or as stated in the MAINDEC test specification "The diskless test can be run with all drives available cabled to the RK8E control. However, the power must be supplied to the drives, and att the drives must be set to the load position."

    Code:
    0200	7301 CLA CLL IAC -> 0001 ACC, CLEAR ALL
    	6742 CLEAR DCLR
    	7326 CLA CLL CML RTL -> RECALIBRATE 0002
    	6742 CLEAR DCLR
    	6745 STATUS -> AC
    	5200 JMP 200
    Are there someone else than me that has runs this controller in a PDP-8a with KK8A? I got the result right sometimes, but it was not stable. I switched out some IC's that I suspected and I actually made it to fail every time. After measuring the signals I suspect that I have a timing issue.

    It would also great if someone could check the IC's E45, E54 and E44. Mine are SN7400's and SN7440, I guess that the faster 74S00 could help...

  5. #55

    Default

    Today I've been testing with other packs in my RK05. The very first disk, which I
    tried a few months ago, went into a total loss at the first head load on it... Woops...
    I did clean the disk and heads, but I think the surface of the disk wasn't as good as I thought.
    So cleaned the heads again...

    From Mattis I got two other 16 sector disks but I refused to put these into the drive.
    So I've arranged a few 12 sector PDP11 disks just to see what happens with head loading.
    Guess what, it loads fine No nasty sweek sounds from the head on the disk surface.

    But the spindle bearing was really REALLY NOISY. Together with the RK05 I got a spare spindle.
    Turning by hand gives a nice sound. So I swapped the spindle. That spindle made is very accurate
    in height. But you have to realign the drive. I don't have an alignment pack. So the disks
    which are formatted in this drive will probably only be readable in this drive. Well, I don't care

    format 1.jpg format 2.jpg

    So no earbuds needed anymore, this spindle runs very smooth...
    The drive lamps READY and ONCYL are on when a disk is loaded.
    The head moves back and forth with the format program. So at least my M993 PCB is
    also doing something right Anders is testing this redesigned card too at the moment...

    But I got a "WRITE STATUS ERROR" So I guess I have to run the drive diagnostics now. Baby steps...

    format 3.jpg

    (The first "RECALIBRATE STATUS ERROR" was because the disk wasn't loaded yet...)

    To be continued.
    Regards, Roland
    WTB: Case for Altair 8800 ...... Rolands Github projects

  6. #56

    Default

    Nice!

    Well, I built your board but I haven't tested it yet. I'm waiting for a spare part to the power supply in my drive. So I'm a few steps behind. Here's a picture of the board...

    m993-cable-assembly.jpg-small.jpg

  7. #57

    Default

    @ Anders, nice to see the build PCB! Good luck with your drive!

    And here a few baby steps! Here is a little movie of formatting a RK05 disk. But I get error messages.
    The first part of the disk formats, then errors start to come up. Every time the head retracts
    is an error message on my terminal. But it is repeating at the same sort of addresses.

    It starts to give an error at DA:1000
    When I get an error I type N for not trying that again and go to the next.
    It stops at many points. but in some area's it runs okay.
    After 1740 it runs to 3000
    After 3740 it runs to 5000
    After 5740 it runs to 7000

    I see some bit repeating in those numbers... Something with bit 2 at least...

    I've attached the Errors.txt in a text file.



    I'm not sure if it is a controller problem or something else. The controller
    passed the disk less tests. Now I have to run the disk test. So to be continued...

    Regards, Roland
    Last edited by Roland Huisman; May 15th, 2019 at 12:09 PM.
    WTB: Case for Altair 8800 ...... Rolands Github projects

  8. #58

    Default

    Okay, one lesson learned when running the diskless RK8E controller test...
    " RK8E DISKLESS PASS COMPLETE " does not mean that your controller is guaranteed fully functional!
    For those who are also going to restore an RK8E: The cylinder address (and other) data which actually goes to your drive
    is not checked with this test. This is because there is no feedback on the cylinder position data lines.

    I was watching the formatting in slomotion , and every time it runs for 0-15 steps. At step 16
    problems start to come up. This corresponds with bit 2 in the accumulator and error messages.
    So I've checked the data with an logic analyser while running the diskless test.
    Now watch the dirty signal on line 4 on the logic analyser.
    IMG_20190517_180200.jpg IMG_20190517_190909_1.jpg

    So lets see where that comes from on the controller. So I attached the logic analyser
    to the 7496 chip before the RK05 bus drivers. The data was normal at that point.
    IMG_20190518_105929.jpg

    So I thought the problem was at the 75452 bus driver itself and replaced it.
    IMG_20190518_100532.jpg

    Well no, it didn't solve the problem. The problem was that there was a very
    little short circuit between that bus line and another data line on the pcb.
    It looked like a bit of tin. Don't know... But I've removed it and it solved the problem.

    So now I got: "RK8E/RK8L DISK FORMATTER PASS COMPLETE" WOOHOO!

    FORMAT PASS COMPLETE.jpg

    This does also mean that my M993D PCB is working well without errors!
    So Jos, Michael and Anders can use the board without any problems.
    I will put the documentation and Gerbers of the M993D on my Github soon.
    (I still have a few of them available)

    Now I have to figure out how I can make that RK05 disk bootable.
    Then I think I will make another demo of the system...

    Regards, Roland
    WTB: Case for Altair 8800 ...... Rolands Github projects

  9. #59

    Default

    Well done! Glad to hear that you got it to run. I'm still waiting on parts...

  10. #60

    Default

    As promised... Cleaned up the mess a bit over here...
    Sorry for the low light in the film...



    I've made a little extension cable on the battery terminals of the RK05.
    Now I can connect a 4.8V NiMH battery outside the drive.
    I don't like batteries in equipment... You never know when they start leaking...

    Regards, Roland
    Last edited by Roland Huisman; May 18th, 2019 at 11:51 AM.
    WTB: Case for Altair 8800 ...... Rolands Github projects

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •