Image Map Image Map
Results 1 to 8 of 8

Thread: 5 1/4 Floppy Drive on a Modern(ish) Computer?

  1. #1

    Default 5 1/4 Floppy Drive on a Modern(ish) Computer?

    Hello everyone, I'm really at a loss here.

    I recently purchased my first IBM compatible computer, a Tandy 1000 SX, and I am desperately trying to make a boot disk.
    I have two modernish computers with floppy controllers one of which supports 5.25 disks in bios. I connected my Tandy drive (its not the model with the powered ribbon cable) and configured the bios.
    Attempting to write the disks in XP with WinImage give the "a: is not accessible the request could not be performed because of an i/o device error", suggesting that XP doesn't recognize it.
    Unfortunately this is my only PC with a floppy controller that supports 5.25 disk drives and it REFUSES to boot to FreeDOS, and even my Linux live CDs wont run on this thing.

    My other option was to use one of my dozens of 1.44 3.5 inch drives as a 720k drive, but im getting similar results with that. On either of my XP era machines with 720k disk support I get WinImage errors like "disk error on track 0 head 0", and attempting to format from DOS gives the error "Disk unreadable". I have used about 5 different models and brands of 1.44 drives, none of which appear to have any jumpers or switches. Is there something else I'm missing when using a 1.44 drive as a 720k?

    I have also ordered a flash memory card IDE converter and I have a hard-card, but I believe I still need to get a working boot disk before I can configure and install a hard drive.

    I am open to ANY suggestions to get this poor Tandy booting, this stuff is pretty new to me as I'm a commodore nerd lol.
    I'm also new to this forum, so nice to meet you

    UPDATE: I got a 3.5" drive to format a 720k disk! Now my challenge seems to be getting the Tandy to read it. Using the same drive in the A position the indicator light comes on when it searches for a boot disk, then halts. Ive tried moving the files from the 320k SX image to a 720k disk, and using a 720k TL image, neither seem to do much. Is there some fancy trick I need to do to get it to read a disk that big?
    Last edited by Stirner; June 4th, 2018 at 04:39 PM. Reason: update

  2. #2

    Default

    Have you tried using omniflop to format/write these instead of winimage? It's fairly versatile and should be able to cope with most things...

  3. #3
    Join Date
    Jan 2013
    Location
    Marietta, GA
    Posts
    2,750

    Default

    For some dumb reason Windows XP does not support 360k drives, and it sticks its nose up at them. If you can boot DOS on the XP machine then you should be able to do something with the drive.

    If you are using USB floppy 3.5" drives to write disks be aware that many USB 3.5" drives lack 720k support, although there are some that do support it.

    You can't just copy files to make a boot disk (well, technically if you know the right boot sector is in place and copy the hidden DOS system files first, it may work). You must write an image file containing a compatible version of DOS directly as a disk.

    Winimage can resize disk images. It can convert 720k, 1.2m, or 1.44m images to 360k provided there is less than 360k space used in the image. It can convert 360k to 720k or large, but keep in mind that the version of DOS must support 720k disks (Most DOS 2.x versions will not).

  4. #4
    Join Date
    Sep 2008
    Location
    Walled Lake, MI
    Posts
    3,543
    Blog Entries
    6

    Default

    +1 for SomeGuy.

  5. #5
    Join Date
    Aug 2013
    Location
    Keansburg, New Jersey, United States
    Posts
    896

    Default

    You could also try Imagedisk ( http://www.classiccmp.org/dunfield/img/index.htm )

    Did you get your images here? ( http://www.oldskool.org/guides/tvdog/system.html )
    -----[ Al ]-----

    3 - TRS-80 Model I, TRS-80 Model 4D, LNW-80 Model I, Coco, 3 - Coco 2, Coco 3, 2 - Tano Dragon 64, C64, C64c, C128, 2 - Atari 800XL,
    Atari 520-ST, Atari Mega-2 ST, Amiga 1000, TS-1000, TS-2068, ZX-Spectrum, IBM 5150, 2 - Apple ][gs, Laser 128, and a butt load of Macs and Intel PCs.

  6. #6
    Join Date
    Apr 2015
    Location
    Austin, Texas
    Posts
    1,234

    Default

    Quote Originally Posted by Stirner View Post
    Unfortunately this is my only PC with a floppy controller that supports 5.25 disk drives and it REFUSES to boot to FreeDOS, and even my Linux live CDs wont run on this thing.
    FreeDOS is very picky about what hardware it will run on, especially on more modern PCs post Pentium III era. The incompatibility usually stems from their versions of memory extenders like EMM386. Usually you can get FreeDOS running by running in safe mode with no drivers, but you won't be able to run anything that uses more than normal conventional memory.

    Not being to run Linux Live CDs is a bit more interesting, this is usually indicative of hardware problems. If you haven't already, I'd suggest running Memtest (www.memtest.org) because unlike Windows, Linux is very sensitive to bad memory. A bad power supply can also cause such problems, the unstable power rails can cause the machine to do all sorts of bizarre things.

  7. #7

    Default

    I guess you could try JEMM386.EXE and JEMMEX.EXE. I went back to MS-DOS and their version of EMM386 because I like to run a fairly complex system and FreeDOS just isn't up to it. Too bad.

    Some Linux distros do balk at some hardware but it's not common. There will definitely be several distros that will boot. If not, then, like GiGaBiTe said, thee is probably something wrong with the hardware.
    WANTED: Cardinal 2450MNP modem.

  8. #8

    Default

    I got the 5.25 drive fully working!
    Thank you everyone for guiding me in the right direction.
    I had to set the jumper to the B position (odd, since my computer only has support for one drive) and format it in FreeDOS with PnP disabled.
    Weird that even windows 98 wouldn't touch it.
    I might mess with the 3.5 drive some more, but right now when I use them both in my Tandy at the same time it acts like the cable is upside down (constant motor spinning).
    Not a big deal since the 5.25 drive is cooperating now.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •