Image Map Image Map
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: IBM PS/2 P70 386-20 Luggage; no screen, no POST, no nothing

  1. #1

    Default IBM PS/2 P70 386-20 Luggage; no screen, no POST, no nothing

    Hi folks,

    I have an IBM PS2 P70 machine - 386 20mhz - "luggage-pc". It doesn't turn on - and I really need your help on this one. I am not bad with C64's and Amigas - I generally know my way around hardware, but this particular period of PC-hardware I am not very familiar with (also, i burned an I/O controller back in days, so im really cautious with this era PCs ).

    So, the story is, I got my companys old computer - and I could take it home with me. My Boss says it worked about a year ago.

    When I plug in mains and turn it on, the power light goes on. The three lights on the keyboard briefly flickers. The harddrive starts to slightly humm, in a kinda familiar fashion but supprisingly low volume. And then everything stop - all that is left is the sound of the fan running. The screen never turns on, the keyboard lights can'T be changed, the pc-speaker never makes a beep - the floppy drives never does a search for disks.

    The machine itself inside is nice. No bulging caps, a bit if rust on some of the metallic shielding, but it doesnt seem to have affected the mainboard. The keyboard is getting 5volts, measured at the plug. The power rails seems to have the correct 5V, 12v, -12v (which actually, is 11.something - but im just writing 12v here).

    The CMOS battery has been removed, and another one has not been installed into the machines.

    I have tried turning it on without RAM installed - same effect as before.

    Its almost like something is holding down some kind of reset line, and stuff just doesnt turn on.

    So, im thinking; fuses maybe ?

    Hope you can help
    Last edited by ChunkLady; June 8th, 2018 at 04:01 PM. Reason: switched "can" to "cant"

  2. #2

    Default

    I don't have a P70, but a few MCA systems. Am I correct in thinking you mean the HDD stops spinning? If so it *could* be that is overloading the PSU. Have you tested the voltages while it is spinning/booted without the HDD?

    Put a BIOS battery in it, There is at least one PS/2 I've had that needs it. Though it would seem reasonable to assume that without RAM it would beep at you anyway.

    PS/2's output POST diagnostics codes to the parallel port. This may give you some info on whats holding up the system. mcamafia.de has a guide on how to read them, and build a device. Just buy a parallel port POST diagnostic thing of eBay, they're so cheap it's not worth the trouble building your own.

    Also I'm guessing you've found "Louie's Ardent tools of Capitalism" site. There will be some useful info there.

    As for fuses I don't know.
    Looking for: OMTI SMS Scientific Micro Systems 8610 or 8627 ESDI ISA drive controller, May also be branded Core HC, Please PM me if you want to part with one.

  3. #3

    Default

    Hi Mr_Slug, thanks for your response

    The HDD .. well, im not even sure its spinning.. or.. its the only thing making a sound, but its about the same sound-volume as my own 1tb moderne HDD, which startles me a bit. I have tried disconnecting the HDD - and it did not appear to have any change to the boot/post situation.

    I was thinking of buying a battery for it, i wouldn't know why it shouldn't work without, but if the CMOS (or similar) is powered by the battery, well - then it might make sense if it cant get anywhere. So might as well get its; its like 9-10$ here.

    I didn't know there was a POSt info on the PRL-port ! I must get a device for this asap Thanks ! I Had found the website, but I had never visited the frontpage apparently (thats google for ya) - so I found a great PDF im going through now

    Thanks !

  4. #4

    Default

    Buy the CMOS battery is a good idea, but I think it should also display at least something, even without the CMOS battery (not sure thou).

    Here's a troubleshooting guide;

    http://ps-2.kev009.com/ohlandl/books/ps2-hmm.pdf

    It's only 500 pages, should keep you busy for a while. One thing you should get is a 'ibm ps/2 reference disk', google it, they are still online...

    I also have a model 70, and I've noticed that something the wires of the speaker get stuck in the plastic pin that fixes the diskette mount. So I start of with a firm visual inspection, to see if there is anything wrong, if the CPU is installed (correctly).

    Do the num-lock etc, react on keypresses? Can you get them off/on?

    Can you try another monitor?

  5. #5

    Default

    I bought a new battery, but it changed nothing :-/

    Also, i invested in the BIOS parallel boot-device (I only had ISA/PCI before that) - and Im not sure I am using it correctly, but when just plugged into the Parallel-port it shortly flickers on 00FF and then turns off. When i power it on with USB (before turning on the P70) it shows "-- FF" (which i guess makes sense) - once I turn on the P70, it goes into "FF 00". And stays there. When using the "Previous" / "Next" buttons, i get "01 FF" "02 00"

    Numlock/Caps/Scroll does not react, but they flicker on/off on boot. The keyboard has 5v (tested)

    My next attempt is to bring on another monitor, and maybe thats where it halts (for some reason, who knows). After that, I might try .. i dont know.. new BIOS?

    I will probably wait with the reference disk until the system at least makes an attempt at POST

    Thanks for your help !

  6. #6

    Default

    I'd pull it completely apart. maybe the cpu isn't seated properly, maybe the hard drive is over drawing the psu. Swap the cpu, memory, etc. Also make sure you are using the correct IBM memory. While standard 72-pin simms fit, they won't work in ps/2 machines.
    It is a mistake to think you can solve any major problems just with potatoes.

  7. #7

    Default

    yes, so - that sounds like something I would do in my holidays in a few weeks I will post images here - if nothing else, hopefully someone can use the debugging for something.

  8. #8

    Default

    Lots of things going on that distract me, but MrSlug made the incantation.

    I just gave away four P70s, so I can't bring one up, however, the issue MIGHT be a DBA-ESDI drive with stiction, and therefor pulls too much starting power. Luckybob has hit the high points. Pull all but one SIMM. Unplug the DBA-ESDI cable, either from the planar, or off the drive's edge connector. Pull all adapters. Reseat all power and signal cables from the planar. Compressed air on SIMM sockets. Buff SIMM contacts with folded bank note.

    Also, the P70 PSU has a funky fan mount, it pulls air through the PSU (and over the DBA-ESDI HD) -AND- from the top half of the P70 case. Is the PSU full of dust bunnies? Though the system should have come up for a little bit before thermal cut-out. Even if the floppy is shot, you would get a 60x error and a not-ok graphic and/or a ROM BIOS screen... Should be beep codes at a minimum for lost configuration...

    I'm thinking the symptoms point to a SIMM or adapter crammed in wrong. You must use 2MB 85nS SIMMs (1MB 85nS might work as well). The P70 only has the PD code for 2MB 85nS SIMMs in BIOS (I'd have to chech SSI). However, the P70 should have thrown a 211 or so for wrong speed or size if the wrong SIMM was used....

    http://ps-2.kev009.com/ohlandl/error...tm#Dead_System

    http://ps-2.kev009.com/ohlandl/error...eshooting.html

    No beeps. No codes. KB lights flicker.

    http://ps-2.kev009.com/ohlandl/8573/8573-P70.html

    If the system does respond, then add things until it bombs once again. Don't be a stranger....

    P.S. modernclassic had someone cram in a 387 (some pins bent or not in socket!) into a P70. Chech CPU / NPU alignment with Pin 1 on the socket!
    Last edited by ardent-blue; July 18th, 2018 at 06:29 PM.

  9. #9

    Default

    Thanks for all your answers. I am back The modernclassic was actually the thing that got me started again

    Just did a full screening of the P70 and looked over the error-guides. The situation is this: the exact same . I turn it on, the fan starts, the harddrive starts spinning - the keyboard shortly flashes - and thats it. Nothing shuts down, nothing gets really hot - nothing releases smoke.

    I tried removing the harddrive, the diskdrive, the ram modules, the shielding, the riser-card, the cables from graphics to screen. The one thing I haven't removed so far, is the graphics card itself (though its basically as much a part of the system as the motherboard itself).

    The voltages i have measured are -11.96v, 11.95v, 4.98v (with harddrive and disk drive attached).

    I did check the pins of the CPU - they look fine. I also reseated the BIOS chips, just to make sure. The RAM used seems to be the actual RAM for the machine (2 pieces of IBM - 80ns). I also checked the fuse (F1) and it has continuity (my model, as far as I know, only has one fuse).

    This is a link to a few images of my system https://imgur.com/a/oE2sH0E

  10. #10

    Default

    I pulled out the graphics card - restarted the machine, and still no result. I started wondering if the pc-speaker might be faulty - so i took it out and tested continuity, but it seems okayish - the isn't a break, so it should be making beeps if there were any errors to report. The pc speaker is here: https://imgur.com/a/I9f4DZW

    My best bet right now is that its halting "for some reason" at "some point" - some lines never being pulled high or low.. however, I have no idea where to start :-/

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •