Image Map Image Map
Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Mac SE Checkerboard pattern after cleaning battery leak

  1. #11


    Is this a multi-layer board? If so there is always the possibility of corrosion on the inner layer(s).
    ☀☀☀ Visit Take Another Step for both computer and non-computer related discussions. ☀☀☀

    If you're looking for DS/DD or DS/HD 3" or 5" floppy disks, PM me. I've got some new, used, and factory over-labeled disks for sale.

    There is a crack in everything. That's how the light gets in. -- Leonard Cohen

  2. #12


    I don't see any layers indication but Macintosh Plus had 4 layers, so I would bet for similar design.

  3. #13


    I cleared all vias in coroded area. Desoldered SCC and ADB chips (that are using this 3MHz clock), what's interesting - clock goes all the way to GLU chip. After removing resistor R23 near BBU (one side to clock source in BBU, other to mentioned chips) I measured clock from GLU - same effect.
    Removed IWM too as it's socketed and shouldn't interfere at this point.

    However (I'm still learning using oscilloscope features) when I paused measurements and scrolled through saved signal - the problem is that clock generated by GLU is just unstable as hell. Single pulse varies by almost 1MHz - that's what confuses scope in normal measurements.

    I replaced most 33uF electrolytic capacitors, three are left original for now.

    As main clock is stable and BBU is getting it for sure, I don't know where to look next.

    Checked RAM slots using oscilloscope - I see all signals required by 256k sticks on each slot. Which is weird as it's supposed to have 1MB or 2/4MB and with 1MB settings, slot 1 and 2 are active, with 2/4MB all 4 slots are active.

    and here I was going to post this but by accident found that I'm stupid -.-
    I looked at CPU pinout the wrong way. Perfect clock is on CPU pin 15. Aghhh... So time to check connections between ROMs and CPU. HIGH rom was also on corrosion path.

    And here it goes! It's partially alive!

    What I found is that both RESET and HALT lines are driven LOW (active) and for some reason they are both short. On working computer I applied 5V to them... and got sad mac face!


    Not sure about error meaning and where/why this short exists (according to schematics those should be separated). Half of chips is still not installed on board for sure.
    Based on Mac Plus schematics I found pullup resistor (R13) for RESET line - 1k, it's ok. So something is driving this low.
    Last edited by kitor; June 12th, 2018 at 12:03 PM.

  4. #14
    Join Date
    Apr 2015
    Austin, Texas


    According to this:

    0000000E means data bus failure
    0000FFFF should be the address where the failure occurred (65536?) The bus could be physically broken, shorted to ground or bad memory.

  5. #15


    Yes, however keeping in mind this short circuit between HALT and RESET + that I'm forcing it to HIGH as something keeps it LOW... that's not weird at all at this moment.

    This short is not caused by BBU (exists with chip removed), nor CPU/under CPU (I cut the trace going to HALT from BBU - there was no short to HALT on CPU but lines were still shorted somewhere on the board.

    Another observation - I can trigger this behavior only with two memory modules installed. When four are installed (independently from jumper configuration), this won't show. But indeed I never checked slot 3 and 4 for proper signals with scope.

    And I think I have explanation for what checkerboard pattern is - just not refreshed RAM state displayed on screen. If I trigger sad mac face, turn off device and turn it on again without keeping RESET to HIGH - I get scrambled image (fading more each time )

    As for bus/memory - all connections between CPU and HIGH/LOW roms are ok, so at least D0-D15 and A1 - A15 seems OK. I used working RAM from Macintosh LC with same result. And there is some communication as sad mac face is coming from ROM (?, correct me if I'm wrong).
    Last edited by kitor; June 12th, 2018 at 10:45 PM.

  6. #16


    I was wrong about HALT/RESET short. They should be - they are literally connected on Processor Direct Slot both on schematics and on board (C12 and B12 pins). So for now something is keeping this low, or there's no reset from Sony UC.

    And you won't believe this!


    So I desoldered audio chip again, and tried resetting CPU by hand (this time on correct connector). And I got usual background!
    After soldering ADB chip, got mouse and no system disk indicator, with disk connected it was hanging somewhere during MacOS boot - I added SCC back and it booted.

    Sound UC is broken, at least RESET line part. It's LOW all the time. I isolated this single pin and after resetting CPU everything boots, and works, including sound.
    I checked whole reset and power circuit, everything seems to be right. Schematics of this part is 1:1 from Mac Plus, just elements IDs are different.

    So it's now up to a) finding working chip, b) designing own reset circuit.
    BTW: Reboot from OS works as it doesn't trigger RESET line.

    After a bit of research, there's a ton of ready to use reset circuits for cheap. So I'll go with option B.
    And photo of working Mac after installing clean OS 7.0.1. It has HD floppy with correct ROMs and IWM happens to be SWIM, so that was easy to pull off with PC and USB floppy.

    Last edited by kitor; June 15th, 2018 at 10:46 AM.

  7. #17


    Well done - that's some decent troubleshooting. A lot of people would not have put the effort in and threw that board away.
    System 80 Expansion Interface located! Thanks to all who helped out and the good people in the NZ vintage computer forums!

  8. #18


    That was a gamble - I found the cheapest (incl. shipping) board for the same price I bought a good desoldering station (ZD-915) that I needed for this, and will be useful for other projects
    Macintosh LC is already waiting with it's bad caps in PSU (no voltages - known issue with this model) and short in all directions on the board (I bet for capacitors again; RAM, HDD and FDD are working).

    I decided that this board is probably repairable after I was able to clean this corrosion quite nicely. Had Commodore PC10-III in the past that board was so damaged I needed to drill a hole to get it off the computer case. Fortunately I had spare board and person interested in chips from damaged one in that case.
    Last edited by kitor; June 16th, 2018 at 12:56 AM.

  9. #19


    Good on you for sticking with it. Great effort!

    My vintage collection:
    My vintage activities blog:
    Twitter: @classiccomputNZ ; YouTube Videos: (click here)


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts