Image Map Image Map
Results 1 to 2 of 2

Thread: LTE 5000 drives over 8GB? (Or: Generic 8GB Boundary issue...?!?)

  1. #1

    Default LTE 5000 drives over 8GB? (Or: Generic 8GB Boundary issue...?!?)

    Hi folks!

    Been working on souping up an old compaq LTE 5000 series laptop for a place to play some of the 90s games I have.

    I'm running into an odd quirk with drives and means to expand storage on this thing. I'm wondering whether anyone has had success in using 8gb or larger drives in one of these.

    Obviously there's the 8GB BIOS limitation (running v7.20 there) but my understanding is that limitation can potentially be worked around by something like a drive overlay. Not ideal, but it should work.

    However, the problem I'm having is that the system hangs on boot whenever I insert a *PARTITIONED* drive that exceeds this limit. (tried an 8gig CF card via IDE adapter, and a 100GB drive that has a cylinder limit jumper to keep the BIOS happy). Doesn't matter if it's one partition or multiple, it still hangs. But not if the offender is unpartitioned (or has a partition in a format the booting OS can't read).

    The place it's hanging is right around where it starts booting from the drive, e.g. where one would expect "Starting MS-DOS..." to show, or similar.

    I was fortunate enough to find a 6GB drive for it which at least got me booting (Dual-boot win98SE and DOS 6.2/Win3.1 via the bootgui=1/FAT16 c: trick) and that put it to rest for now. But I since obtained a multibay adapter for adding a second HDD, reviving the issue as the same thing happens with a 6GB boot drive, and the large drive in the secondary space. I'm kind of hoping to plop a bunch of ISOs on a second drive for easy access vs keeping a small boat anchor's worth of software CDs on hand)

    I have reason to believe it should be possible; I have seen places listing 25gb drives for this system with compaq part numbers online during my searches... and my understanding of the limitation was that it only prevented you from seeing more than 8gb of space until you transferred to a system that no longer uses BIOS calls to determine drive capacity/access, aka Win98 io.sys

    I'm going to keep tinkering to find a fix, but hoping someone here might be able to short circuit that process and offer a tip as to what's going on. It's probably something obvious/silly as it's been a while since I worked with physical hardware and W98/DOS.

    Thanks for any advice sent my way!

  2. #2


    Quick update - installed Ontrack disk overlay and it fixed the issue; it's now happily booting from a 100GB drive.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts