Image Map Image Map
Results 1 to 2 of 2

Thread: Installing packages - Solaris 8

  1. #1

    Default Installing packages - Solaris 8

    Hi all,

    Sorry for all the Sun/Solaris related questions recently. I'm trying to get my Ultra 5 into a usable configuration and it's far more complex that I thought.

    My latest problem is Solaris 8 - I want to install some packages to compile software from source. This includes things like gcc, automake etc.

    After some searching around I found someone who has some precompiled Solaris packages for most things. Website is here and the files for Solaris 8 are here.

    I downloaded gcc and installed it as per the instructions (decompressed the file, then ran pkgadd -d *filename*). This worked and it reported a successful installation at the end.

    My problem then begins when I try to use gcc. Running a random ./configure comes up with 'gcc not found'. I then tried whereis gcc and got no results. I am assuming that the pkgadd SHOULD have put gcc into the path; but maybe it didn't. I don't want to manually put things into the path as I need to install 50+ packages this way; and that will take an eternity.

    Have I done something obviously wrong? Does the system need a reboot after installing the package to update the PATH (only thing I haven't tried)?

    This reminds me of early linux days. You'd try to install / compile something and spend weeks trying to sort out dependencies and random problems like this.... I'd like to avoid spending that much time!
    System 80 Expansion Interface located! Thanks to all who helped out and the good people in the NZ vintage computer forums!

  2. #2
    Join Date
    Mar 2009
    Bainbridge Is., WA


    pkgadd just installs the package and does nothing with your environment. I would look for gcc in a bin directory under a package directory under /opt or in /usr/local/bin and add that to your path.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts