Image Map Image Map
Results 1 to 6 of 6

Thread: IBM 5170 post code 201

  1. #1

    Unhappy IBM 5170 post code 201

    Hi !
    I'm having some difficulties repairing my 5170 (type 3), let me explain :

    At boot, it is always displaying the code 000000 FFFF 201 and hangs there.
    If I boot it with supersoft diag roms, everything looks okay (with the same quirks as described on minuszerodegrees.com)
    IMG_20180809_200503.jpg

    I've tried flashing fresh EPROMs with the latest IBM BIOS : same!
    I've also tried resetting the CMOS to no avail...

    So I really don't know what to do at this point, can someone help me ?
    Thanks

  2. #2
    Join Date
    Jan 2007
    Location
    Pacific Northwest, USA
    Posts
    27,846
    Blog Entries
    20

    Default

    On MZD's 5170 error code list, the following note is given under error 201:

    Displayed on screen in the format of "AAAAAA BBBB 201-Memory Error",
    where AAAAAA is the hexidecimal address (in bytes) of the failing word and BBBB shows which bits in the word have failed

    NOTE: If the BBBB portion (failing bits) contains many "F", example: "FFFE", then it is highly likely that non-existing RAM is being tested.
    For example (one of many), this would occur if the machine SETUP is configured for 640K of RAM, but only 512K is fitted.
    For example (one of many), a RAM card has failed completely.

  3. #3

    Default

    Yes, I do know the error code 201 explanation, but as you can see my RAM is tested good by supersoft diag and my error code indicates the first byte of RAM is in error so it can't be a memory size detection problem...
    I have no RAM card installed and if the first 16k bytes of ram were bad, the motherboard would appear dead...

  4. #4
    Join Date
    Jun 2006
    Location
    NC , USA
    Posts
    1,054

    Default

    Similar error found in this forum thread :

    http://www.vcfed.org/forum/showthrea...00000-FFFE-201

  5. #5
    Join Date
    May 2006
    Location
    Melbourne, Australia
    Posts
    5,818

    Default

    Very interesting that the IBM BIOS ROMs have issue testing RAM, but the Supersoft diagnostic ROMs do not.

    One difference that I expect between the two is timing; I expect that the Supersoft diagnostic does its RAM tests later.

    What power supply are you using? I have seen problems caused by XT-class power supplies, and there may be some clone AT-class power supplies that are a problem (e.g. faked POWER GOOD signal not delayed enough). Just a 'shot in the dark'.

  6. #6

    Default

    I'm using my test power supply which is from a way more recent 486 DX2 50Mhz system, I'm not using the original 5170 power supply because I don't want to switch it on and off repeatedly for testing purpose (I didn't recap it, for now it is 100% stock)

    I will try with the original 5170 supply, I will also try connecting the PG signal a few seconds after power on.
    I wanted to try another BIOS (a third party one), but I'm out of EPROM and I don't have a UV lamp...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •