Image Map Image Map
Results 1 to 5 of 5

Thread: Tanner 64k Static RAM with AM2716DC EPROM

  1. #1

    Default Tanner 64k Static RAM with AM2716DC EPROM

    For use in my Imsai FIF project.... I'm attempting to run Martin's MEMON80 monitor from an AM2716DC EPROM placed at the top of a 64k COEX (Tanner/ Digital Research) Static RAM board. I burnt the EPROM with an ME2700. I put the ORG at F800 The eprom appears to match the .PRN. I took an educated, perhaps WAG, guess and placed the EPROM in position X31 and moved the associated jumper from RAM to ROM. I placed it in the Imsai 8080 and examined F800 which didn't look like the monitor and I could deposit to the location. I'm guessing X31 is not the top of the 64k address space.

    Any suggestions?

    Interesting the slight variations of this board. Digital Research, Tanner, Coex... This board doesn't have the RAM/ROM at every position like others do.

    Code:
    F800 =         MEBASE	equ	0F800h	;Base address of Memon/80 code
    ; ...
    F800           	org	MEBASE		;Memon/80 ROM start
    F800 F3        MEINIT:	di			;(00)Cold-start entry point
    F801 AF        	xra	a		;So code can recognize Memon
    F802 57        	mov	d,a		;and we have a spare 0 around
    ; ...
    Tanner64kSramEprom.jpg
    ---
    KF7CRU @jhalbrecht @TheRetroWagon Looking for Solid State Music SB1 please DM me.
    http://www.theretrowagon.com/vcf-west-2017/

  2. #2

    Default

    My board is a newer rev the way you describe it. Distant memory but I seem to recall a jumper(s) on that card aside from the local ROM/RAM jumper that also needs to be open (or closed) for the IMSAI/Altair type S-100 systems that have the older bus to use the top of RAM like that. ("J or X 5"?) Also, I assume you have nothing else installed in the box at least at the moment when you're doing your testing. Another thought, try with the last 4 RAM chips removed i.e. stop at 56K
    @ BillDeg:
    Web: vintagecomputer.net
    Twitter: @billdeg
    Youtube: @billdeg
    Unauthorized Bio

  3. #3

    Default Doh! - Success!

    Quote Originally Posted by jhalbrecht View Post
    For use in my Imsai FIF project.... I took an educated, perhaps WAG, guess and placed the EPROM in position X31 and moved the associated jumper from RAM to ROM. I placed it in the Imsai 8080 and examined F800 which didn't look like the monitor and I could deposit to the location. I'm guessing X31 is not the top of the 64k address space.

    Any suggestions?
    Best suggestion would be to stop making assumptions!

    I assumed X0 - X31 = 32 chips. It's X1 - X32 And those last two chips were right to left not left to right.

    Anyway in the light of day after considerable tossing and turning I took another look. Reconfigured the EPROM into X32. MEMON80 came right up!

    Back to creating media over here; Creating boot media for Imsai FIF project
    ---
    KF7CRU @jhalbrecht @TheRetroWagon Looking for Solid State Music SB1 please DM me.
    http://www.theretrowagon.com/vcf-west-2017/

  4. #4

    Default

    X32 is clearly labeled on my board (just checked).
    @ BillDeg:
    Web: vintagecomputer.net
    Twitter: @billdeg
    Youtube: @billdeg
    Unauthorized Bio

  5. #5

    Default

    Quote Originally Posted by billdeg View Post
    X32 is clearly labeled on my board (just checked).
    It's pretty clearly marked on my board too! ;-)
    ---
    KF7CRU @jhalbrecht @TheRetroWagon Looking for Solid State Music SB1 please DM me.
    http://www.theretrowagon.com/vcf-west-2017/

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •