Image Map Image Map
Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Amiga 500 with a lot of upgrades

  1. #11
    Join Date
    Dec 2012
    Location
    Orlando, FL, USA
    Posts
    188

    Default

    Ok, so I spent considerable amount of time cleaning the Amiga 500. It looks really good now. Once I assembled everything together it still works. However even after opening and cleaning the A590 when it is connected to the Amiga 500, the Amiga 500 refuses to power up. So I am back to the beginning.

    Next step is I will use my oscilloscope to test the pins on the Zorro bus. Something must be happening on the A590 board to stop the 68000 CPU inside the Amiga from powering on. I found a pinout for the Zorro II bus (for A500) and I will check for power pins and clock pins.

    I have even removed the HDD from the A590 and the Amiga still does not power on. I have connected a different HDD inside the A590 (just to the power, not the data cable) and the HDD is getting power and spins nicely.

  2. #12

    Default

    The A590 (which is the same as the 2091 for the A2000) has room for 2MB Fast RAM as that is needed to have a productive WB experience. 512k-1MB Chip RAM is not enough for a HD. The 2MB Fast RAM really helps, and helps speed up the HD.

    Also, you might have older ROM's on the A590. What version of Kickstart do you have? The latest Revision ROMs are 7.0. If you need a set I have one for sale. Two ROM chips. PM me.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •