Image Map Image Map
Results 1 to 4 of 4

Thread: SPARC 5 Ultra does not get to login screen ?

  1. #1

    Default SPARC 5 Ultra does not get to login screen ?

    I have an old SPARC 5 Ultra which boots from the hard disk ok but stops after boot. See screen shots attached. Has anyone seen this error before. I have applied the workaround because the battery on the NVRAM is dead. I have setenv the boot to be from disk and disabled net.

    In the attachment it shows that at boot it hangs at starting rpc services.....

    If anyone knows why this ight be please let me know. The Sun is not networked and I thought I disabled network connection.
    Attached Images Attached Images

  2. #2

    Default

    It's trying to bind to an NIS master. You need to boot into single-user mode, and remove the 'nis' entries from /etc/nsswitch.conf, then reboot.

  3. #3
    Join Date
    Oct 2008
    Location
    Kamloops, BC, Canada
    Posts
    5,287
    Blog Entries
    41

    Default

    Looks like the first thing that ran was fsck and it found problems. Could be from an unclean shutdown or could be form the disk failing.
    I see it's waiting for you to enter GO. I assume you tried that?
    = Excellent space heater

  4. #4

    Default

    it hangs because it's looking for the NIS Master server (or maaaaaybe an NFS server) and it can't find it. boot single user, unset the NIS domain, and take references to NIS out of /etc/nsswitch.conf. Check /etc/vfstab for NFS mounts and remove them, if you find any.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •