Image Map Image Map
Results 1 to 10 of 10

Thread: Model 4 gate array drive problem

  1. #1

    Default Model 4 gate array drive problem


    Forgive me I'm better with the old Apple ][ computers but wanting to get my Model 4's and III working.
    I have a working M4P that I test disks on so I know the floppies are good.
    The gate array model 4 I have was working well with both drives being good boys until I attempted to make
    a disk copy. The drives hung so I reset. Then the system displayed a high ASCII character just in front of
    the word Diskette at startup. I poked around a bit noticing nothing smelly, I had already replaced MR. RIFA cap.
    But I didn't like the slight bulge of a 2200uF 10V cap on the PS. I replaced it with a 2200uF 10v smaller in dimension
    cap but it blew after 30-40 seconds. I replaced that with a larger dimension Nichicon 2200uF 10V and the PS seems good.

    The computer starts well with the drives not connected, Cassette? (and no high ASCII character) and all seems normal to
    me with the lower drive plugged into the MB, but I cannot get the known good floppy drive and disk to 'bite'. It seems
    weak or not getting good logic. This drive worked well and the heads are clean. The floppy boots my M4P.

    Is this PS or possibly MB related? What to check next?
    As always help is greatly appreciated - you guys know far far more than I.

  2. #2


    If it starts up fine without the floppies connected, I'd start with a check of your power supply voltages.

  3. #3
    Join Date
    Mar 2016
    Pikesville, Maryland


    I agree with Pete --- check the PS first --- I could send you a replacement power supply for you to try out (no cost) .... if it solves your problem then we can proceed further.

  4. #4


    That is what I was figuring might be the place to start. It does start well without the floppies so the drag on the p.s.
    I'll have to check the voltages but not sure where to check. Might be interested in a better p.s. but would like to check out
    this one first. Where are what to check?

  5. #5
    Join Date
    Mar 2016
    Pikesville, Maryland


    Check voltage along the power rail (the big long connector) on the power supply. See what readings you get

  6. #6
    Join Date
    May 2013
    Williamstown Victoria Australia


    Could you try Just 1 Floppy drive at a time and then the other. it may be that one of the drives is hungry for power.

    Good luck

    Ray Whitehurst
    If it ain't Broke then PLEASE DONT fix it.
    Procrastinators Unite.
    I keep telling you I am Not Pedantic.

  7. #7


    I've cleaned and checked both drives and tried one today. It started to grab a disk then gave Disk Error.
    I know the disk is good as my M4P loves it. So It does seem to me to be the PS.
    I'll test the rails as suggested.

  8. #8
    Join Date
    Mar 2012
    Augusta, Georgia, USA


    I've had floppy drives go bad where they will stop another one from working on the same chain/cable. They can pull too much current, or have logic problems, etc.

    Also, the TRS-80 floppy system has bus termination concerns and they affect different drives in different ways. If it's not right, it will not read or do strange things.

  9. #9


    The old drives also had problems their spin rpms. 300 rpm is the standard to fast or to slow and all you will get is disk errors. If you can put the drives into a good machine, try running a disk checker, TRS-Ian's copy of Newdos/80 has several utilities for troubleshooting hardware problems. Another issue is the head alignment
    if it is off again the dreaded disk error.

    My 2 cents

    Collection: TRS-80 Model 3 w/autoboot FreHD, TRS-80 Model 4 (X2), TI-99/4a (X2) w/PEB, Timex Sinclair ZX-81 w 16K module, Raspberry PI (X5), 1u eServer running Linux, Intel Brick Computer running Linux, Dell Optiplex 160 (X2) 1 running Win7, 1 running Linux, Dell Optiplex 755 running Win10, Mini MAC (Apple)(X2), a hacked together AMD A6-5400K running Win10, and several laptops running everything from XP to Win10 (X5+)

  10. #10


    Thanks. I'll have to get a copy of his Newdos/80.
    I do have one M4 working and will do the swap.
    I thank you all for great ideas.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts