Image Map Image Map
Results 1 to 5 of 5

Thread: Help me resurrect my old PS/1

  1. #1

    Default Help me resurrect my old PS/1

    Last time I visited my parents I dug the old IBM PS/1 2155 "Consultant" 486 out of their attic, and I'm trying to get it working again. The good news is that everything looks clean internally, and it appears to power up OK. I get a clock error, which is hardly surprising since the CMOS battery is 25 years old. But when I hook up the hard drive (which had been disconnected) I get a couple of errors (see pictures). According to this page, this is a "Drive seek failure" error. I do hear the drive spin up, but I don't hear any seek sounds. Also, it shows up in the BIOS as "Not Installed", but it seems to detect that there's something there. Is this drive shot, or is there something I can do to try to recover it?

    A couple other questions: I was surprised that the BIOS didn't have an interface for entering drive parameters like I remember from those days. Is this going to be a problem if I want to get one of these CF adapters? Or will it just autodetect and work correctly?

    Also, the floppy drive lights up on boot and makes typical floppy drive sounds. I no longer have another computer that can write to floppies though. Any suggestions on a decent USB floppy drive?
    Attached Images Attached Images

  2. #2
    Join Date
    Feb 2011
    Location
    NorthWest England (East Pondia)
    Posts
    1,913
    Blog Entries
    10

    Default

    I know the PS/2 range had a "Reference Diskette" that was used to configure the machine. There was probably something similar for the PS/1. Whatever holds the config has perhaps died (dallas chip perhaps) so its "forgotton" it has a hard disk. You can download some of the info here:-

    ftp://ftp.mindcandydvd.com/pub/drive...011/index.html

    were there no floppies put in the attic with it...
    .. I use some of the Toshiba USB floppies...
    Dave
    G4UGM

    Looking for Analog Computers, Drum Plotters, and Graphics Terminals

  3. #3

    Default

    Thanks for the link! Mine is actually a 486 in a more traditional desktop chassis rather than the AIO-style 286, but it looks like that site has a page for my model too:
    ftp://ftp.mindcandydvd.com/pub/drive...133/index.html
    Looks like the hardware service manual has the jumper settings for the drive, which should be helpful. I don't think they were printed on the drive anywhere. It also refers to an "advanced diagnostic diskette", I'll have to see if I can find a copy.

    Fortunately, the battery seems to be a standard CR2032, so it should be pretty easy to replace.

    I'm sure the original floppies are somewhere in their attic, but they weren't with the machine. I'll have to do some more searching next time I'm there.

  4. #4

    Default

    check master/slave/csl jumper, or is the HDD spining?? listen if it's spinning well and it's heads seems moving naturally .

  5. #5

    Default

    I finally got a little more time to look at it this morning, and good news! The drive was just set to slave mode. The jumper settings aren't printed anywhere on the drive itself so I had to check the service manual, but once I set it to master it booted right up. What's more, it has an old copy of OS/2 Warp 3 on it, and a bunch of the games that I remember playing in the 90s.

    Attachment 48712

    Unfortunately that's about all the time I have to mess with it today, but I guess my next questions are:

    If I get a CF adapter is there any way to clone this drive to a compact flash card? I'm reluctant to trust a 25-year-old hard drive too far. Is it even possible to run OS/2 from a CF card? I remember it being more temperamental than DOS/Windows regarding hardware support.

    Also, on the hardware support topic, this machine doesn't have a sound card, but I have an old AWE64 Gold in the closet. Any idea if this card will work with a pre-PnP machine? Or with OS/2, for that matter?

    Finally, before I found the jumper settings I ordered a USB floppy drive off of Amazon and wrote a FreeDOS boot floppy. The floppy drive in the PS/1 reads it and I was eventually able to boot, but it looks like the ejector mechanism has some problems (I had to get the needlenose pliers out). Is there a good reference for repairing these drives?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •