Image Map Image Map
Results 1 to 1 of 1

Thread: Need some help with an ATI Mach32 PCI graphics board

  1. #1
    Join Date
    Oct 2018
    Location
    Chattanooga, TN, USA
    Posts
    8

    Question Need some help with an ATI Mach32 PCI graphics board

    I've had this cute little HP Pavilion 6736 on my parts shelf for a while ... the last time it was used it was a Windows XP machine. In order to have XP running halfway decent, the memory had been upgraded from 64MB to 512MB (the max for that motherboard) and the CPU was upgraded to a 1GHz Pentium III (from the original 667MHz Celeron).

    The hard disk had died and so I decided to get rid of the IDE stuff completely (the motherboard only does 66 MHz IDE, pretty lame). I found an Adaptec 2940UW, a Pioneer DVD-303 DVDROM drive, a 146GB 10000rpm Maxtor server drive and a 100MB Iomega Zip drive so I put that all in. Also added a 3C905 ethernet card.

    The reason for this little project is to build a little workstation to run Windows 98 (and several old applications) as well as OS/2 Warp 4.5 - and then there is that one DOS Application I really want to revive which requires either an ET4000 or a 8514 compatible graphics board. I also wanted to have 16 bit colors for Windows 98 and OS/2, so at 1024x768 I need 2 MByte of video ram. The ET4000 never had 2 MByte (the ET4000W32 did but that old DOS application does not work with the W32, it requires an original ET4000), so the only choice left for me was to get my hands on a Mach32 (which is 8514 compatible) with a PCI interface (so that it fits that HP Pavilion) and 2 MByte of video RAM (to get 1024x768x16 in Windows 98 and OS/2).

    Well, I managed to get one on eBay. Unfortunately I'm having problems setting up the card. "Setting up the card" back then meant to run ATI's DOS INSTALL utility to tell the card which video resolutions are allowed and where the memory aperture should go and things like that. All this information is stored in a little onboard EEPROM.

    Long story short - that INSTALL utility does not work. I have the newest version I cound find, version 2.6 from 1995. The Mach32 board says in its BIOS:
    Code:
    ATI MACH32 PCI BIOS
    P/N 113-23000-106
    1993/12/9
    The Mach32 board itself works. The 1024x768 resolution works in Windows 98. 800x600 does not work because the previous owner disabled it in the EEPROM. OS/2 does not boot because the 640x480 resolution has to run at 60Hz for OS/2 and it is currently setup for 72Hz within the EEPROM.
    How do I know what's inside the EEPROM as the INSTALL utility does not work? I took the source code from the old Linux svgalib project; they had a nice utility do read out the MACH32 EEPROM contents. I made a DOS program based on that source code. So this is how I know.

    Now for the INSTALL problem: INSTALL complains that it cannot find the MACH32 BIOS. But it is right there, at C000:0000, where it belongs. And the card works. And INSTALL seems to find the Mach32 chip itself because if I run INSTALL without the Mach32 board I get a "Mach32 adapter not found" error.

    What can be the problem preventing INSTALL from running, or better, from recognizing the MACH32 BIOS? Is it my 512 MByte of RAM (I have no smaller RAMs anymore, so I cannot downgrade)? Is it the processor speed (I disabled both L1 and L2 caches which slows the P-III down to a crawl, still no luck)? I boot an original PCDOS 7.0, no HIMEM.SYS or EMM386 or any other of that stuff.

    So the questions are - if anybody out there has that same graphics board and can run INSTALL:

    Which version of INSTALL exactly are you using?
    Did you encounter similar problems like I have with INSTALL.EXE?

    I'm about ready to launch the Debugger and try to find out what the root cause might be, but INSTALL.EXE is 200 kBytes, that might take a while to debug my way through that thing. So if anyone can provide any hints, I'd be very grateful.

    Markus
    Last edited by Baer; October 11th, 2018 at 08:26 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •