I recently purchased a defective Original MessagePad (OMP) for a good price hoping to fix it blindly. And I did; 2 compact electrolytic capacitors inside had leaked and gone bad, there are 3 in total inside the device but 1 is not the typical compact/surface-mount kind that goes bad and can probably be ignored safely for now (My LCR meter showed it well within spec).

Symptoms? On power-up the screen is garbled and glitches terribly with occasional flickers of the newton logo and eventually sometimes showing calibration text/crosses - but mostly just random lines and black bars.
Also no start-up chime. Watch here https://www.youtube.com/watch?v=m_ctiJ473-g

When first removing the back cover C1 had a white fog around it, it's a surface mount and is located right next to the speaker wires. Original value is 100uF @ 4V. I only had 100uF @ 25V on hand with a slightly larger 6.4mm diameter body and it fit fine. After cleaning the residue off with isopropyl alcohol and replacing it I got sound - a start-up chime! But the video was still broken. In my LCR meter C1 still measured 100u but with very high ESR (almost 1K)

All the other capacitors visible are tantalum solid-state caps and should be fine. Plus the one obvious through-hole cap that isn't the compact type to go bad, typically.

So I removed the logic board to have a look at the other side; and lo! One more surface-mount electrolytic not too far from the display ribbon also with residue around it.
C51, valued 3.3uF @ 35V. I had 3.3uF @ 50V on hand (4mm dia, original was also 4mm. I test-fitted a 5mm and it also fit, but 6.4mm cap did not allow the board to sit flat).
Clean and replace. Reassembled.
And I have a beautiful working OMP now. Useless handwriting [S]mutilator[/S] recognition and all.
C51 did not register on my LCR meter at all, completely bust.

A member of another forum tried this repair and had success as well. So coincidence or not, I recommend all OMP/MessagePad 100 have these 2 caps replace as they are prone to leaking and damage, regardless of symptoms. Other models in the line may have similar issues but I don't have personal experience with them. (Well, I won a dead 110 on ebay that was lost it the post )

Album here:
https://imgur.com/gallery/69J7YWl