Image Map Image Map
Results 1 to 8 of 8

Thread: Tandy 1000

  1. #1

    Default Tandy 1000

    I bought this last weekend. Seller informed me about the problem.
    TBH I wanted it for the keyboard and amber monitor
    Anyway...I want to try and fix the unit itself too so my other 1000SL has company.
    I must admit that I am a TOTAL Tandy noob and a beginning-moderate retro pc dude

    The seller told me the first time when he bought it and turned it on, it worked.
    Now this is showing on the screen. My initial thought was a RAM problem??!!
    The screen blinks and when I increase contrast and brightness, the second half of the screen also becomes visible.

    I reseated and cleaned pretty much all the chips except 1(a Zylog one).
    When I turn it on now, I see 640k ram and then it goes to the blinking garbled screen again.
    Removing the 2 banks of chips results in this screen:

    Removing the EEPROM
    Is this a RAM problem or EEPROM or.....?

  2. #2


    Can't seem to edit my title or my initial post :/
    The model is a 1000 SL.
    Yesterday, I removed the left RAM bank and then it sees less RAM but the same blinking screen. I swapped all chips from both banks but still the same.
    Clueless about the problem.

  3. #3


    No one ?
    I would really like to revive this system.
    Yesterday, I used 4 chips from the left RAM bank to replace 4 DRAMS used for video according to the service manual (U6,7,8 and 9) but still the same blinking garbled screen.
    I ordered new DRAM chips too but it will take a while to get here.

    I also tried an external Hercules card but same result.

  4. #4
    Join Date
    Mar 2016
    Georgia, USA


    I've been following the thread but I don't have anything useful to add. Perhaps you should check all the jumpers and verify they are at default settings.

    Also, is it possible it's attempting to boot in CGA mode on a monochrome monitor? Is that still togglable with CTRL-ALT-SHIFT-V on a 1000SL?

  5. #5
    Join Date
    Jan 2011
    Portland, Oregon
    Blog Entries


    if you don't have this link already, there may be something there to help:


  6. #6
    Join Date
    Nov 2013
    Ontario, Canada


    You will have to troubleshoot it yourself at this point.

    A big possibility may be a faulty power supply. You can check voltages there first, and then start going down the list by checking capacitors and resistors on the board to make sure you are getting continuity and proper resistance. Beyond that, you'll have to research more about the chips on the board to find VCC and Ground, and do some additional checks to make sure they are doing what they should be doing. A multimeter will be your friend.

    Good luck!

  7. #7
    Join Date
    Sep 2017
    Porter County, Indiana, USA


    The 1000 SL has dos in rom. Can u try a different rom from another SL

  8. #8


    Hmmm did not get any notifications so sorry for the late reply.
    A multimeter is definitely on my to-buy list.

    Still waiting for the RAM chips ATM.
    I used my IBM 5153 CGA monitor but it changes nothing.
    Forgot to take a picture, but if I remove U6 to U9, the screen doesn't blink but I get something else. I'm at work ATM but will post a picture ASAP.
    Bought a VGA 8 bit card for an XT machine,but when it arrives, I'll try that too.
    I believe the 2 yellow chips between U6-U9 could be the culprit too? I thought I read they are RAM chips too. Will need to look it up again in the reference manual.

    There is 1 jumper I believe but that one is on default.

    I have my working 1000SL so I can use PSU, EEPROM and BIOS chips from that one but I don't want to screw that one up


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts