Image Map Image Map
Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Sparcstation 5 on a VME card

  1. #11
    Join Date
    Oct 2011
    Location
    Durham, Durham, United Kingdom
    Posts
    102

    Default

    Quote Originally Posted by m_thompson View Post
    Nice backplane, I helped design it.

    The newest ones have switches in the connectors to take care of the IACK and BG daisy-chain signals.
    The older ones have gates on the backplane to take care of the IACK and BG daisy-chain signals.
    The oldest ones have jumper pins to take care of the IACK and BG daisy-chain signals.
    Hi, I'm hoping that since you have some knowledge of this backplane you'll be able to advise me

    I'm just about finished the main power wiring for the backplane and now I'm on to the utility connector that is supposed to run to the front panel. In the documentation it is labelled as the following pinout:

    SYSFAIL
    SYSRESET
    ACFAIL
    +5v
    GND

    I'm not using any power monitoring so I'm ignoring ACFAIL. However, would I be correct to assume +5v and GND are actually outputs, rather than inputs? I'm assuming since the use of this connector would be to drive a monitoring device or status panel, they would be providing +5v and ground signals?

    Also, I get the function of SYSRESET as a warm reset - though I'm finding it difficult to locate the documentation that indicates whether it needs to be connected to +5v/+12v or to ground to activate.

    Lastly, SYSFAIL. I understand this signal can be generated by any of the boards in the system. However, is the signal that then appears on this pin suitable to drive a LED?

  2. #12
    Join Date
    Jul 2014
    Location
    Rhode Island
    Posts
    1,053

    Default

    We make several devices that connect to the utility connector. The simplest device just includes several LEDs that are powered from the +5v and are activated SYSFAIL, SYSRESET, and ACFAIL signals. The more complicated devices monitor fan RPMs and temperatures, and under certain conditions will drive the SYSFAIL, SYSRESET, or ACFAIL signals.

    The VME specification says that the SYSFAIL, SYSRESET, and ACFAIL signals all require 48mA driver chips. If you limit the current for the LEDs to less than 48mA then you could connect them directly to those signals. I believe that our display module has a SN7438 to buffer the backplane signals and drive the LEDs.

    Switch 7 on your CPU board is determines if the CPU board will drive SYSFAIL, and SYSRESET backplane signals.
    Switch 8 determines if your CPU board has the slot 1 functions enabled. It should.
    Last edited by m_thompson; January 6th, 2019 at 07:25 AM.
    Member of the Rhode Island Computer Museum
    http://www.ricomputermuseum.org

  3. #13

    Default

    Nice homemade VME chassis
    Available for exchange (20-300 pcs available per part number):
    MC68000 DIP 16Mhz, DSP65002,XC56303PV80, ADSP-2101KP-50, AD1848, 80C188XL12, PAL20X10, PAL20L8, PAL20R6, PAL20R8, DSPB56721AF, FDC9229BT

  4. #14
    Join Date
    Oct 2011
    Location
    Durham, Durham, United Kingdom
    Posts
    102

    Default

    Enclosure is nearly finished - some minor cosmetic issues to address (fill in a few blemished and then stain it), but it works and is now hosting the Force SPARC 5V card:

    IMG_20190217_155620.jpg

    ... I'm also happy to see that the card is apparently working fine; I made up a simple 3 wire serial cable that mostly works (some text corruption, so that's one to revisit) and I can see the Openboot monitor start, grab the rarp request, feed it a tftp boot image etc. SCSI to connect up next and see if it's happy to talk to my SCSI to IDE bridge.

    Next after that is testing the MVME 68k card and then move on to the additional Transputer VME cards once the Sparc half of the system is running.... as there is a driver to interface the Transputer VME cards with Solaris 2.6. I've got a couple of PPC Transputer cards (in addition to vanilla INMOS T400 and T800 chip cards) that won't fit in anything else that I'd like to try getting up and running.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •