Image Map Image Map
Results 1 to 2 of 2

Thread: Commodore 1571 Troubleshooting

  1. #1
    Join Date
    Jul 2017
    Portland, Oregon, USA

    Default Commodore 1571 Troubleshooting

    Hi guys, I have my very orange Commodore 1571 I'm trying to fix. Here are the symptoms:

    - Drive powers up normally
    - Drive does _not_ reset when powering on the connected computer
    - Accessing the drive, it does attempt to read the disk. The Green LED blinks rapidly while it's trying, the head kind of moves back and forth quickly for about 1 twice, then it gives up and the green LED blinks more slowly now. Typically what it blinks at when the you have a bad floppy disk.
    - Accessing, on the computer the error is always ?FILE NOT FOUND ERROR
    - I have tried a different power supply. (No change)
    - I have tried the drive mechanism in another 1571 and it works fine.
    - I swapped the ROM and 6526 CIA with known good ones and no change.
    - None of the chips are hot -- the CIA and ROM get warm.

    I went through Ray's troubleshooting guide here:

    Looking at the error codes, trying to validate the disk, I get back:
    Error# 21 Read Error on track 18, sector 0

    If I try to "New" (format) the disk, I get same error but on Track 0. The head doesn't actually seem to see around other than the slight movement I indicated above. The only thing he mention in the troubleshooting guide for Read Error 21 is U14 (7404) ... so I guess I should try changing that out. I'm just worried it's that hybrid that is bad as it's the head amp and stepper control -- which might explain the lack of seeking ability. That part is clearly unobtainium -- although why wouldn't the drive reset when I power on the machine?

    Anyone have any tips?

    I guess worst case I have a spare 6526 spare CIA. :-/
    -- Adrian

  2. #2
    Join Date
    Jul 2017
    Portland, Oregon, USA


    Ok I actually fixed the drive. The not resetting when powering on the computer led me to U8, a 7406 logic chip. It handles amoung other things the reset signal over the serial port. When I grounded the output pin, the drive reset but on the scope I could see the input to U8 from the computer but nothing on the output pin.

    I found a spare chip on an old junked 286 motherboard, removed it and swapper the chip on the 1571. When I powered it up, the reset signal from the computer was now working. Then for fun I tried to read a disk and wouldn't you know it, the drive now worked perfectly!

    I hadn't mapped out what they other gates were going to, but clearly they were important.

    So nice to have a very happy 1571 Now for retrobrite!
    -- Adrian


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts