Image Map Image Map
Results 1 to 2 of 2

Thread: Setting auto answer modems for V.21 fallback?

  1. #1

    Default Setting auto answer modems for V.21 fallback?

    Hi all,
    not really "hardware" but I don't know if another forum is more suitable(?).

    I'm setting up a test bed for modems, well, mostly for old modems like acoustic couplers and 300-1200 bps modems. Now, in this part of the world, 300 bps means V.21 modulation.
    I've settled for an asterisk exchange server with a small 2 ports ATA (analog to SIP telephone adapter). The analog ports work very well, I can make voice calls and audio is good, no delay (obviously it's all local), I've configured the highest quality codec etc...
    I then thought about using one of the more "modern" modems I have as a terminal server, on a serial port of the asterisk server so I could just login into the linux system as a way to test the communication.
    The problems started now: I have several modems (from 1970's to 1990's mostly).
    1) Single protocol ones (V.21 only, V.22 only): I prefer not to use them as the answering one as it would force me to change it whenever I need to test a different modulation.
    2) "Intellingent" modems (the ones that recognize AT commands) without V.21 support: yes, I have three of them, probably not intended for EU market at that time. I have to exclude them also.
    3) Intelligent modems with V.21 support and Rockwell chipsets (mostly 14k4 and 28k8 ones): I can't make them test for V.21 modulation long enough in the AA training phase. I have tried like 6 of them and all produce the correct V.21 answer idle tone for a fraction of a second (I can tell by the flashing CD led on the originate modem and it starting producing the originate idle tone), but then the answering modem settles on another tone until timeout. This is driving me mad, I've read several manuals looking for the right command (don't suggest ATB0, I've done that) to make the modem attempt a correct V.21 phase during auto-answer, but the behaviour is always the same.
    4) Intelligent modems with V.21 support with non-Rockwell chipsets (Mostly USR modems, one Multitech too), they correctly produce the V.21 answer channel idle tone for long enough and in some cases they give a connect message, but they seem to be quite deaf on this modulation. V.21 only to V.21 only on the same lines works fine, so signal S/N and levels must be ok.

    Ok, I'm stuck, I would like to solve the mistery Rockwell problem, if anyone really knows how to configure those modems to really attempt to answer with a valid V.21 tone.
    Ideas?

    Frank

  2. #2

    Default

    Well, replying to myself, just to record some progress.
    I haven't found a way to make Rockwell 28k8 chipsets-based modems to produce the V.21 Answer tone long enough for the originate modem to assert CD, answer with the originate idle tone etc...
    But, disabling the echo cancelling options on the ATA (the analog to SIP telephone adapter) made all the non-rockwell modems deal perfectly fine with V.21 modulation.
    I don't know if this is a common problem on the analog telephone adapter or just the SPA-2102 has an echo cancelling algorithm that affects the correct FSK modem operation, but for me totally solved the problem.
    Frank IZ8DWF

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •