Image Map Image Map
Results 1 to 3 of 3

Thread: FreHD Help !! Help !!

  1. #1

    Default FreHD Help !! Help !!


    My wife just bought me a FreHD for Christmas and I installed it today on my 4P. I can't get it to work. When I connect it to power, the green LED blinks for an instant, then nothing. When I insert the SD card it blinks again, but I cant get anything to work.
    I have tried the ldos bootdisk that came with the package and nothing. I tried using autoboot versions of CP/M 2.2 and LSDOS, but nothing...

    I checked the power supply and its right at 5 volts. I checked the SD card on my PC and it seems ok. I even reformated it fat32 just in case, and tried it again.
    When I watch videos of Frehds being used, the green LED stays on for a few seconds, but mine just flashes and stays out. Is this ok?
    I checked the docs and they say that when connected to power, but not to the computer, the red LED should light up, but when I tried this nothing happens, so I think it may be a problem with the board.

    Any ideas what to check??
    Aside from the proper hard4-0 file, do I need any other files on the SD card?


  2. #2


    Problem fixed, sort of...
    It WILL boot the auto-boot lsdos file from the hard drive if I hold down the F1 button, but won't boot from a boot-disk...

  3. #3
    Join Date
    May 2013
    Williamstown Victoria Australia


    Have a talk to the person you purchased it from.
    You will need a ROM replacement in the 4P Perhaps

    If it ain't Broke then PLEASE DONT fix it.
    Procrastinators Unite.
    I keep telling you I am Not Pedantic.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts