Image Map Image Map
Results 1 to 5 of 5

Thread: Dug up a neat AT&T 286 - Take a look!

  1. #1
    Join Date
    Nov 2013
    Location
    Rhode Island, USA
    Posts
    7

    Default Dug up a neat AT&T 286 - Take a look!

    Haven't touched my 12th Edition of Scott Mueller's Upgrading and Repairing PC's in close to 5 years. But here it is, back on my desk...

    The reason? Well I dug up an AT&T Model 6286/EL WGS Desktop

    I pulled the cover, it's stamped September 1990 on the bottom. Massive amounts of dust! Massive! Both 6-pin power connectors were unplugged. One SIMM removed and laying in the case.

    Plugged in the connectors, I thought I was slick remembering the "black wires touching" rule, but alas, they're keyed... Pushed in the line voltage power switch, PSU fan comes alive, front panel power LED lights green, and the floppy drive has some activity. POST beep.

    My next task was giving every inch of the computer a dusting and cleaning. Here's the drive bay/PSU portion of the LPX-style case cleaned a bit:

    IMG-0967.jpg

    Motherboard removed and dusted a bit:

    IMG-0969.jpg

    It's a Western Digital WD286-LPM12 board. Integrated IDE Controller, Paradise Video, PS/2 keyboard & mouse headers:

    IMG-0958.jpg

    Phoenix BIOS chips, dated 1990:

    IMG-0972.jpg

    The glorious 12.5Mhz 286 CPU, an AMD N8OL286-12/S, unfortunately soldered to the board:

    IMG-0977.jpg

    4 x 30-pin 80ns 256k SIMMs with Parity, by Texas Instruments (TM256GU9B). I installed the fourth removed SIMM and it's registering fine. Have not run any memory tests yet:

    IMG-0973.jpg IMG-0975.jpg

    3270 Terminal Emulator Card, a DCA IRMA 005026:

    IMG-0978.jpg

    Quantum ProDrive 40MB IDE HDD:

    IMG-0957.jpg

    So I had it down to the bare chassis. Cleaned everything pretty well, and then blew out the PSU with some duster spray, and reassembled. Plugged it in and turned it on. Soft, fast-paced, rhythmic beeping from the PC speaker, the power LED blinking. It would do this in 2-3 second cycles. No video output, no drive power... I opened up the PSU. No bulging caps, nothing out of the ordinary. I think that first startup in 25 years did it in...

    I rigged up a hack temporary solution to get the machine to power up and it worked quite nicely:

    IMG-0980.jpg

    I am looking for a replacement LPX PSU. The bottom right mounting hole is not in the standard location, and the case has clips to secure the PSU, so I may be looking for a used identical model:

    IMG-0966.jpg

    Back to the testing! Here's the machine POSTing:

    IMG-0981.jpg

    I was quite certain this BIOS would require a floppy to access the SETUP program, but sure enough, it's built in. Ctrl + Alt + Insert accessed it.

    Speaking of keys, here's what I found along with the machine. An AT&T branded Keytronics Professional KB3270 Keyboard with DIN to PS2 adapter. Missing one key as shown:

    IMG-0985.jpg IMG-0986.jpg

    The BIOS is complaining about the RTC losing power. Any suggestions on battery replacement for this board? Until then, every boot means accessing the BIOS SETUP first to set the HDD type.

    I did a full PKZIP backup of the hard drive contents and will be wiping to reinstall a clean version of DOS.

    I do have some accessories which may be suited for this machine. One is a rather neat Sony SCSI CD-Caddy CD-ROM drive, with a Future Domain SCSI card. Would that work in a machine like this? I've been hanging onto it, waiting for a machine with an ISA slot for the card.

    Now RAM. Everything I see for this board lists 4MB as maximum. Should I be sticking with parity SIMMs? The originals are 80ns. What speed should the replacements be?

    For the Hard Drive, I'm quite fine with the 40MB drive, and the smallest drive I have would be a 1.2GB WD Caviar, which I doubt would be supported by the BIOS without the use of software like Ontrack Disk Manager or similar. Boy that Quantum whines!!

    If anyone has any information at all on these systems, or the WD motherboard, please let me know! If you'd like any specific pictures, let me know!

    -Nick

  2. #2
    Join Date
    Nov 2013
    Location
    Rhode Island, USA
    Posts
    7

    Default

    More progress on the machine!

    I had to deal with the defective Dallas RTC chip right away. Luckily, WD decided to provide a socket rather than soldering directly to the board. This made my modifications rather easy. I gained access to the chip's battery contacts, and soldered a battery I had laying around, from an IBM ThinkPad. It worked like a charm:

    IMG-1003.jpg IMG-1005.jpg IMG-1006.jpg IMG-1008.jpg IMG-1009.jpg IMG-1011.jpg

    I have ordered a replacement identical Iriichi PS2682L PSU, and that'll be coming in a few days.

    When I first plugged the machine in, and afterwards, with the temporarily PSU, I never was able to get the Quantum HDD to spin up. Well I'm not sure what has revived it, but after swapping in a newer drive (Seagate Medalist 4.3GB, configured as 504MB in the BIOS), and then trying the Quantum again, it spun up and I was able to PKZIP the drive's entire content to about 8 floppies. In the couple days after, however, the BIOS has been throwing an "Hard Drive Initialization" failure. The drive spins, but once the BIOS checks the drive, I can hear a slight decrease in pitch from the drive, for about half a second, then the failure comes up...

    I've installed DOS 6.22 and booted the machine successfully with the newer (and much quieter) Medalist, and installed the Future Domain SCSI drivers, and MSCDEX for the Sony CD-ROM. I had quite a battle getting the drive to fit into the 5.25" opening in the front bezel of the case. Are 5.25" floppy drives--what this slot was actually meant for, no doubt--a tiny bit smaller? All three of the others, and a newer 52x drive are the same dimensions... Here's you can see the FD card and drives:

    IMG-0997.jpg IMG-1001.jpg IMG-1015.jpg IMG-1016.jpg

    I love these older Sony drives for their nostalgia, but they are VERY sensitive to temperature. Normally the drives only recognize the CDs after they've "warmed up" a bit, and rather unreliably at that. These are some of the first-generation Sony CD-ROM drives though, so I get it.

    As an aside, I found this magazine article about this very machine:

    286ad.jpg

    I have removed the terminal emulator card. My next steps are to find some 1MB SIMMs as well as a proper sound card. I'll also be doing the "Retr0bright" procedure to the case and drive bezels, and perhaps the keyboard to get them back to white.

    Speaking of the keyboard, I will have to investigate the DIP switch settings underneath once I find some information on it.

    -Nick

  3. #3

    Default

    Jealous of this machine! I have the 386 version, which has a slightly different, taller case. That CD drive is great. I still need a 286 machine to play with, that ISN'T a Tandy 1000 series machine.

  4. #4

    Default

    I have the identical 6386sx, I haven't booted it in a while. It was running Linux 1.2. Someday I need to try to boot that up.

  5. #5
    Join Date
    Nov 2013
    Location
    Rhode Island, USA
    Posts
    7

    Default

    Thanks guys. The PSU is coming in Friday, and this is coming in today:

    s-l16007.jpg s-l1600.jpg s-l16008.jpg

    I accidentally threw out the last PS/2 mouse I had a while ago; thought I had another one around somewhere... Oh well. I guess I HAD to get this one :P I don't think it was a bad deal at $12.50 including shipping, new in box.

    I've found some articles on those 1x Sony drives and a common failure. I was talking earlier about how they are sensitive to temperature and will refuse to recognize discs until it's warm. It'll spin the discs around three times, then eject. I've checked with the top cover off, and the PCB folded away, in a dark room with an empty caddy, and the lens/laser mechanism is clearly working and moving as it should.

    Looks like bad electrolytic caps is the common failure point on these drives, and their Apple and NeXT-rebranded counterparts:

    NeXT CDROM Restoration
    AppleCD 150 Capacitor Repair

    I've verified this is likely the issue by swapping the SCSI board out into the other physical drives, and they're all doing the same thing with this SCSI PCB. The caps are on their way from Mouser.

    Nick

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •