Hi,
I am fixing my Apple III machine. The first symptoms are that it does not show anything on the screen.
Apart from that, it is possible to ctrl-reset it, it will kick off the FDD, or to ctrl-apple-reset it and it seems to go into debug mode, there are beeps in response to some commands entered on the keyboard.
I started with recapping and testing almost all logic chips, except a few which my tester does not test. No change.

Then I traced the problem with the blank screen to the absence of SCRN signal going from 6522(G2) to the video logic chips. This signal actually enables chips that output the create the video signal, while the video sync is still provided correctly.
I tried replacing 6522 with a working chip, no change. If I look at the port signals, it outputs constantly the following values: ROMSEL1=1, ROMSEL2=1, ALTSTK=0, RWPR=0, RESETLOK=1, SCRN=0. Also, the CS1 chip select signal is correct, but the CS2 is almost always 1. I am not sure if it goes to 0, which would select the chip briefly after reset, if yes, than for a very short time.

Ok, so I tried to connect the SCRN signal manually to +5V and it actually enables screen output. I can see the correct screen area displayed and what looks like character boundaries, but the characters content is actually a complete mess. If I enter debug mode, I can actually see the changing characters, but they are all garbage.

The 20 ohm big resistor on the memory board (+5v variant) is getting very hot - it looks like it is a radiator itself, but is it correct?

I thought I would ask for hints going forward, to the two problems. Reverse engineering it even with the service manual takes pretty long time.

Thanks
Pawel

IMG_1454.jpg