Image Map Image Map
Results 1 to 4 of 4

Thread: ThinkPad 755CD Won't Boot - Speaker Light Flashes

  1. #1

    Default ThinkPad 755CD Won't Boot - Speaker Light Flashes

    I acquired a ThinkPad 755CD from someone this week. He told me it was broken and described the symptoms but it was cheap enough I decided to take the chance.

    The issue is that nothing shows up on the screen, not even BIOS. When i power it on, I can hear the HDD spin up, the HDD spindle operate for just a second, the CD drive seems to go through a boot process and I'm able to open the CD tray. When i hit the function key and one of its corresponding keys up top, I hear a beep that seems to come through the speakers.

    I've soured the internet for information and have found a few posts. This actually seems to be a fairly common problem so I'm hoping one of you seasoned pros can share some of your unwritten knowledge with me.

    So far I've tried booting the computer a bunch of times in a row. I've tried this fast, slow, waiting, not waiting etc etc. There's no other way I can do this. I read this somewhere as a possible solution. I've also tried hitting the reset button on the back panel with a pen tip and holding that down for 10 seconds while flipping the power button a few times.. Read that somewhere else. I've also tried opening the computer and removing the HDD, RAM, etc. The battery is already gone, I can see some mild corrosion on one of the connectors so it makes sense that it would have been removed and should have no effect on the computer's ability to operate (as long as it's plugged in). I also tried toggling the external monitor / display off function keys a bunch of times in case the issue was that it was setup to show on an external screen only.

    The guy I bought this from says it worked fine for years and then one time, after having let it sit for about 6 months, stopped booting. He has no further info for me.

    I see motherboards for sale on eBay, I'm wondering if that's the best next step. I'm not sure how to install one but I'm sure it can't be too hard.

    What do you guys think? I really hope I can salvage this thing.

  2. #2

    Default

    Hello there!

    I'm not an expert in laptops, but try the following: Connect an external monitor, and turn on the computer. After that, try pressing the monitor/display key. If the video signal is visible on the ext. monitor, it could be that the LCD screen is broken. If not, then probably the video chip or the motherboard is broken. Also, when turning off the laptop, does it beep? All (old) ThinkPads make a beep every time they turn off, so if yours doesn't, then probably the motherboard is dead. So yes, probably you'll have to replace it (Unless you're able to find out what's wrong with it).

    If it helps, here's a video of a working ThinkPad 755CD (and shutdown), that way you can see what's supposed to do

  3. #3

    Default

    I have a 755CD and i fixed the issue, there is a board that is connected to the screen and the mainboard, iirc it's the mpeg video decoder or something related to video processing, that board has caps that leak and fail, giving the exact issue you have. I fixed it replacing all the caps and cleaning the board to stop corrosion if any.

  4. #4
    Join Date
    Dec 2007
    Location
    Texas Hill Country
    Posts
    113

    Default

    Not that it matters, since the OP already got his system fixed and posted up on eBay, but I just acquired a 755CD last weekend for beyond cheap (maybe 5 bucks? it was part of a lot of other vintage stuff). Anyways, my system would POST, enter BIOS, and that was it. Nothing beyond that, not even an error message. The battery was corroded to hell, and I've noticed that darn near EVERY SINGLE ROUNDED EDGED BATTERY leaks like the Titanic. Amazingly, I was able to successfully rebuild one of these batteries, but in the future, I stay away from them.

    With that said, I opted for a system board replacement. The system board is exactly like what you'd find in a 755CE or 755CX, depending on processor. Mine had a Pentium 75, so obviously, I'm saving that for a 755CE upgrade. Popped in a spare 755CX system board and reattached all the daughter boards. There's the mWave board, the DC-DC board (mine had the Lithium Ion DC-DC with the LiIon battery connector), and then a riser for the MPEG board (which also depresses the keyboard suspend switch and has its own switch on top). It's a little tricky taking apart, and past experience has told me to be VERY careful with some connectors (cold solder joints). Did this and the system works great, with one caveat - the battery connector has so much corrosion from the leaking prior battery, that even sandpaper couldn't get it all off. I ordered one that I'm waiting for, as I'll be using this with LiIon batteries.

    As far as leaking caps, that wouldn't surprise me, but these boards seem to be fairly resilient. The only complaints I've had are with the rounded edge batteries leaking. 755C/750 series batteries seem to be okay, and for whatever reason, I've never noticed any leakage. And for the curious who want to rebuild these batteries, they use Toshiba cells, but the proper cell is a 4/5A battery (like the Sanyo HR-AUL).
    IBM Computers: 5150 (16-64K, 64-256K), 5160, 5161 expansion unit (several of these), 5170 (regular and Tempest) PS/2 Mods 30, 40SX, 50Z, 55SX, 60, 70, 77 (Lacuna & Bermuda), 80, 85, 90 XP.
    Vintage ThinkPads: 300, 360C/CE/CSE, 365X, 701C/CS, 720C, 730TE (tablet), 750C/P (color and tablet models), 755C/CE/CD/CDV/CX, 760ED, 770, 560/E, 600E/X.
    Vintage UNIX workstations: 2/120, 3/75, 3/60, SS 2/5/20, Ultra 2 Enterprise, HP 715/100, several RS/6000s ............And a bunch of other stuff

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •