Image Map Image Map
Results 1 to 2 of 2

Thread: Help to fix a Toshiba T1200

  1. #1
    Join Date
    Apr 2019
    Location
    Niteroi-RJ Brazil
    Posts
    2

    Default Help to fix a Toshiba T1200

    Hi,

    I got a not working Toshiba T1200 and i'm trying to fix it.

    The LCD is broken.

    The power supply PCB is not working to. All electrolytic capacitors has leaked, a fuse has blown and a tantalum capacitor exploded.

    I've replaced all damaged components and the power supply still not working. I stopped to work on this PCB for now.

    I tried to power on the computer using 5V, from an ATX power supply, directly on the motherboard JP12 connector.

    The computer has powered on, the FDD started to read a disk and after enable CGA output was possible read boot messages on composite video output.

    After power on two times the computer has stopped to work. On next morning, powered on one more time and stopped again.

    I realized electrolytic fluid over PJ16 connector. I washed the motherboard to clean this fluid and the motherboard still not powering on.

    With an oscilloscope I confirmed that all ICs receives 5V from power supply.

    All clocks for 8086, 82C53 and DMA are beeing generated correctly by IC11 (Bus Controller).

    The address and data bus lines on 8086 and BIOS IC are not changing. The CPU seems freezed.

    When a press reset button, the pin 24 (RESET) on 8086 do not change.

    Unfortunily, the Maintenance Manual does not list all JP16 (other power supply connector) pinout. I don't know if there is any missing signal preventing the motherboard to start and before washing the board the electrolytic fluid made some kind of contact between the pins.

    Any suggestions of a test or tip that I can do?


    Photo of motherboard:

    https://www.dropbox.com/s/mywftl54yeytkos/t1200_mb.jpg

    Maintenance Manual:

    http://www.minuszerodegrees.net/manu...e%20Manual.pdf

    Thanks a lot.

    Sorry for my bad english.

  2. #2
    Join Date
    Apr 2019
    Location
    Niteroi-RJ Brazil
    Posts
    2

    Default

    It is working!!

    Thank you modem7 for your book suggestion. Sams IBM 5150 helped me a lot.

    The reset signal was missing, it comes from power supply PCB pin 5.

    Following PJ16 connector traces, I found the function of each pin.

    Toshiba T1200

    PJ16

    1 - IC6 - EXP/MEM IC - Pin 56 - RPDAT1: Receive PS data
    2 - IC6 - EXP/MEM IC - Pin 59 - SPDAT0: Send PS data
    3 - GND
    4 - RESET BTN (???? maybe +5V. when button is pressed a capacitor is charged, making a reset pulse.)
    5 - IC11 - bus controller - PIN 49 - PS RESET - IC 17 - PIN2 - (pulse to ground for CPU reset)
    6 - +5V - VRAM power
    7 - GND
    8 - +12V - RS232 positive power
    9 - -9V - RS232 negative power
    10 - GND
    11 - IC6 - EXP/MEM IC - Pin 54 - LBATO: low battery signal
    12 - -22v - LCD negative power
    The next step is resuscitate the HD.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •