Image Map Image Map
Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: XT boot problem after 1701 error w/ WD mfm controllers

  1. #1

    Default XT boot problem after 1701 error w/ WD mfm controllers

    I'm trying to sort out a bunch of strange behavior I'm experiencing with hard drive controllers in an XT machine.

    This is on a 5160 XT machine I've been using on my bench for some light drive testing work. I have 3 different models of WD controllers, all have "WD super bios" and are supposed to work with ST-225 drives.

    I have two ST-225 drives which are verified good and working. Both have been recently low level formatted and are working fine.

    Here's the behaviors I'm seeing that don't make sense:

    1) The machine will not boot from floppy if there is a 1701 error. For testing, I insert a controller card without a drive attached, really just for the purpose of booting up to check the ROM, run sstor /romlist to check the super bios drive table, etc. but the system gives "non system disk" errors on the floppy drive following the 1701 error. This is using the standard IBM XT floppy controller. Doesn't make any sense, as I'm expecting the machine to still boot from floppy after the 1701 error. I tried one of the other controllers ... same thing, no boot from floppy after 1701 error. Machine boots perfectly fine from floppy without the controller installed, AND will boot from floppy if there is a hard drive connected, but not if there is no drive connected and 1701 error.

    2) Another controller, a WD-1002S-VX28 ??? The model number is partially covered by a sticker which has "61000134-05 F300" and the ROM is 62-000094-031. This controller works with one of the ST-225 drives, but absolutely refuses to work with the other. In fact, it refuses the other drive so bad that the computer will not boot from floppy here either, except this time the machine just freezes instead of "non system disk". The drive on this controller sounds like the heads are smashing into a wall. I have no reasonable explanation for why it works with one drive and not the other. Both drives are good ST-225s and work with other controllers. Makes no sense. I don't like the way this controller makes my drives sound anyway, because this one seems to want to smash heads into stuff, but it still works with one drive and not the other.

    3) One controller, a WD-1002A-WX1 seems to generally work with the ST-225s, but sometimes shows up in Speedstor with 4098 cylinders. Sometimes it shows up with the correct 615 cylinders. I haven't made heads or tails of why sometimes the drive params are different, but this controller works with both ST-225 drives.

    Thoughts?

  2. #2

    Default

    Wow, I think I stumped the know-it-alls

  3. #3
    Join Date
    Sep 2012
    Location
    Indiana, USA
    Posts
    485

    Default

    I use an XT, and a 5150 motherboard for testing on the bench. I have tested many WD MFM controllers and ST-225s, as well as many other MFM drives. I haven't experienced these issues. I'm suspicious of your motherboard or maybe the floppy controller. Do you have another 8bit PC motherboard to try to see if the symptoms follow the controllers?

  4. #4

    Default

    Thanks fatwizard... I have many other boards, so I think I'll do another round of testing and figure out if the motherboard, floppy controller or both are perhaps contributing to the problem.

  5. #5
    Join Date
    Jan 2013
    Location
    Marietta, GA
    Posts
    3,050

    Default

    I *think* I may have seen the behavior described in #1 before, but it was a while back, and I don't feel like pulling apart a system to test right now.

    Keep in mind that the 1701 error can be generated for a number of different reasons. Some of these reasons may incorrectly leave the environment in an unusable or unstable state. Putting a controller in with no drive is not really a normal use case, so may not have been tested. It probably errors out after failing to see a "ready" signal from the drive.

    #2 is a stranger problem. I'd suspect there really is some problem with that drive, perhaps a bad track zero detection. Does this controller let you dynamically configure the drive and specify step rate? If not, then one possibility is it is hard-coded for a higher head step rate and one drive is coping with this while the other is not. If it does let you specify step rate, try a slower one.

    #3 does not really surprise me much. Determining the CHS value of an unformatted dynamically configured drive on an XT controller involves a bit of voodoo. I'd say, as long as you get it to work eventually, just roll with it.

  6. #6

    Default

    Thanks SomeGuy, that makes a lot of sense. I'm going to test the 1701 error on some different boards and try to determine if there is a reasonable expectation that the machine should boot from floppy after 1701, but you're probably right that the 1701 leaves the system in an unstable state.

    I think you are right about the step rate too ... I believe the rom drive table in that controller is not actually intended for an ST225.

  7. #7

    Default

    Quote Originally Posted by chris_nh View Post
    I'm going to test the 1701 error on some different boards and try to determine if there is a reasonable expectation that the machine should boot from floppy after 1701...
    After a 1701 I get a 'Press F1 to resume' on my XT and it then boots from the floppy.
    PM me if you're looking for 3" or 5" floppy disks. EMail For everything else, Take Another Step

  8. #8
    Join Date
    Sep 2012
    Location
    Indiana, USA
    Posts
    485

    Default

    I just tested this on my 5150 test motherboard that is setup on the bench right now, 640K, standard IBM floppy controller, 360K drive, and with no hard drive attached the system throws a 1701 and then just boots to the floppy drive. No other messages. The controller I used is a WD1002S-WX2A with the super bios ROM. The working ST-225s I have all setup without any strangeness coupled to one of several WD controllers I have here, but they don't always respond exactly the same. These old drives can develop drift from their original specs, and work with some controllers and not others.

  9. #9
    Join Date
    Feb 2012
    Location
    New Zealand
    Posts
    2,611
    Blog Entries
    2

    Default

    I've also had weird behavior before, like an ST11M that wouldn't LLF/Configure an already tested ST225 but worked fine with other drives (including other ST225s).
    I have also had that exact behavior when using some cheap Taiwan HD-FDC cards before (infuriating) in combination with certain MFM controllers.

    Boringly, my solutions on both occasions was to just use different hardware until I got a working solution.

    I'd double check the XT has it's floppy drive switches set correctly (unlikely the cause, but meh, worth a check).
    And with the "Super BIOS" you want to use the built in configuration routine, normally this is accessed by running debug and typing "g=C800:5". This will create a configuration record on track 0 and perform the low level format. Not very helpful if you can't boot from floppy, but that might explain the weird results in SSTOR.

    Just my quick thoughts, may not be useful.
    WTB: IBM RT Parts and Accessories, and AOS.
    Twitter / Discord / YouTube / Twitch

  10. #10

    Default

    So after some testing, I am able to re-create the 1701 boot problem in other machines:

    5160 XT machines
    11/08/82 and 5/9/86 BIOS
    WD1002A-WX1 "super bios" MFM controller (NO drive connected)
    Single floppy drive on IBM floppy controller (w/ sw7&8 both on for 1 drive configuration)

    Results in 1701 error (2 beeps)
    Press F1 to resume

    The machine will not boot from any known good bootable floppy disks. The result is a "non-system disk" error. I have tested this with multiple WD cards as well. If the controller is swapped for an original IBM Xebec type controller (10mb), no drive connected, the machine will boot from floppy after the 1701 error.

    This leads me to the conclusion that the WD super bios cards are causing the machine to be not able to boot from floppy after 1701 error w/ no hard drive connnected, which is an interesting behavior. I have not yet tested this on any 5150 machines, but this is fun to test.... so if you want to try it, disconnect the mfm hard drive cables from the controller and try to boot from a floppy to see if it works or not. If you get a "non-system disk" error, take note of the motherboard BIOS version and model of hard drive controller.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •