Hi all. I have been collecting third party disk drives for the 8 bit Atari, and I finally managed to get a Rana 1000 a while back. The drive didn't work, and after chasing that problem for a week, I finally found an open trace on the controller board. After that was repaired the drive worked, and would boot from a single density or a enhanced density disk, but would not switch densities without cycling power. I recapped the power supply and replaced the regulators as the 5 volt line was a touch low and the display leds flickered when the drive was in operation. This changed nothing about it's operation though.

After much Googling it seemed it might be the version of the drive's firmware causing this. I found a couple of copies of ROM images for the Rana 6502 based drive online. One, at Thunderdome (http://atari.fox-1.nl) that was labeled as a standard ROM for the drive dated 1984. The second one was called RANA 6502 UltrSpd.bin , and for the life of me I can't find the site were I found that one again.

The chase begins. I have one 2732 EPROM, so I erase it, and program the standard ROM file into it. I install it in the drive in place of the original PROM chip. With this firmware, the drive won't read anything. It goes to tack zero, and tries and tries to read the disk, but I only get boot errors. I read the original chip, and did a quick compare of the two file. They are not identical, very similar, but actual evaluation of the code is beyond my skill set. For some unknown reason, I did not save the original code. When I reinstall the original chip the drive still refuses to read anything! The PROM apparently got corrupted somehow during the process.

I erase the EPROM and load the ultrspd file. With that firmware, the drive will read and write single density, but nothing else. No enhanced or double density operation at all.

Summary. The issue seems to be firmware, but I can't locate any other copies of the Rana firmware. Some of these drives used an 8031 CPU, and some used a 6502. Mine is a 6502 model with a 4 Mhz crystal. The firmware is different depending on the CPU of course.

Does anybody have any experience with these drives, or maybe a copy of the ROMs?