Image Map Image Map
Results 1 to 9 of 9

Thread: Pericom terminal power supply - ideas ?

  1. #1
    Join Date
    Nov 2017
    Location
    UK, South East
    Posts
    321
    Blog Entries
    1

    Default Pericom terminal power supply - ideas ?

    Folks,

    this is the power board from a Pericom 6807AAB Serial terminal.

    The bridge rectifier in the top right starts smoking on power up - it does this whether the power supply is connected to its downstream load in the terminal or not. I suspect a short somewhere downstream in the power supply itself.

    I have no circuit digram for this device so am having to try and work through to determine what is causing the problem.
    The BR (a PW02) is sourced from a transformer 24AC tap and has the gold coloured 4700uF 25V smoothing cap across its output.

    I'm suspicious about the capacitor as its the same specification as the others shown but a different type - from the silkscreen possibly looks like it should be physically much bigger.

    There is not much evidence of any excess load related heat further into the PSU circuit.

    Thoughts please ?



    IMG_20190527_104246455.jpg

  2. #2

    Default

    Quote Originally Posted by zippysticks View Post
    Folks,

    this is the power board from a Pericom 6807AAB Serial terminal.

    The bridge rectifier in the top right starts smoking on power up - it does this whether the power supply is connected to its downstream load in the terminal or not. I suspect a short somewhere downstream in the power supply itself.

    I have no circuit digram for this device so am having to try and work through to determine what is causing the problem.
    The BR (a PW02) is sourced from a transformer 24AC tap and has the gold coloured 4700uF 25V smoothing cap across its output.

    I'm suspicious about the capacitor as its the same specification as the others shown but a different type - from the silkscreen possibly looks like it should be physically much bigger.

    There is not much evidence of any excess load related heat further into the PSU circuit.

    Thoughts please ?



    IMG_20190527_104246455.jpg
    Looks like a straightforward linear regulated power supply. A common mistake on these supplies (I don't know why o earth) is fusing *after* the smoothing capacitors, while one much better approach would be fusing one leg of the AC input, but I digress.
    Basicly these supplies have the following configuration:

    AC -> bridge rectifier -> smoothing capacitor -> fuse -> linear regulator (IC, discrete, whatever) -> smaller capacitor

    If the rectifier smokes even with no load and with its fuse removed, it's probably either the bridge that's shorted or its smoothing capacitor that's shorted, or both (since a diode operating into a short, becomes another short usually for overcurrent junction failure).

    One can easily check if a capacitor and/or the diodes are shorted with a multimeter.

    HTH

    Frank IZ8DWF

  3. #3
    Join Date
    Nov 2017
    Location
    UK, South East
    Posts
    321
    Blog Entries
    1

    Default

    Thanks Frank,

    yes the smoothing orange cap for that rectifier is shorted so I have ordered a full replacement set.

    While they are being delivered I will deal with the screen 'cataract' problem. (see picture).

    One thing that puzzles me is this brown liquid leak - apparently from around the bottom of the tube. It's a sticky brown odourless liquid that I'm not sure is some sort of lubricant/adhesive from around the copper tube band that has heated and run. Anyone seen this before ? Is it 'normal' ?

    You can see this in the second picture below:

    IMG_20190527_131407519.jpg
    IMG_20190527_131045027.jpg

  4. #4

    Default

    I don't usually replace what hasn't failed (I mean the other capacitors, in this example), but that's an habit that few have I think.
    The brown liquid might be foam or a glue that degraded into that form with the age and the thermal cycles probably, there should not be any liquid substance in a typical CRT.

    Frank

  5. #5
    Join Date
    Nov 2017
    Location
    UK, South East
    Posts
    321
    Blog Entries
    1

    Default

    Well the power supply is fixed - a mixture of short circuit tantalum capacitors and open circuit large smoothing capacitors.

    IMG_20191005_170508772.jpg

    It appears to have an almost identical firmware setup to a VT100.

    IMG_20191005_171252258.jpg

    Happiness didn't last too long as it now looks like some of the 2114 RAM chips have had it.

  6. #6
    Join Date
    Sep 2006
    Location
    Silicon Valley
    Posts
    2,021

    Default

    could you dump the firmware and character generator and take some pictures of the logic board?

  7. #7

    Default

    Quote Originally Posted by zippysticks View Post
    Thanks Frank,

    One thing that puzzles me is this brown liquid leak - apparently from around the bottom of the tube. It's a sticky brown odourless liquid that I'm not sure is some sort of lubricant/adhesive from around the copper tube band that has heated and run. Anyone seen this before ? Is it 'normal' ?
    I had identical leaks from my Pericom 7800 terminals which were left in a hot conservatory over several summers. Never did find the source, also got the cataract problem but will probably just sell these as 'spares/repair'.

    Regards,
    John

  8. #8
    Join Date
    Oct 2008
    Location
    Kamloops, BC, Canada
    Posts
    5,786
    Blog Entries
    44

    Default

    Quote Originally Posted by zippysticks View Post

    One thing that puzzles me is this brown liquid leak - apparently from around the bottom of the tube. It's a sticky brown odourless liquid that I'm not sure is some sort of lubricant/adhesive from around the copper tube band that has heated and run. Anyone seen this before ? Is it 'normal' ?
    On some CRT's the PVA bonding material for the safety glass doesn't just develop cataracts but also begins to break down and liquify.
    = Excellent space heater

  9. #9
    Join Date
    Nov 2017
    Location
    UK, South East
    Posts
    321
    Blog Entries
    1

    Default

    Quote Originally Posted by 1980s_john View Post
    I had identical leaks from my Pericom 7800 terminals which were left in a hot conservatory over several summers. Never did find the source, also got the cataract problem but will probably just sell these as 'spares/repair'.

    Regards,
    John
    Let me know what you want to sell please.

    Thanks.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •