Image Map Image Map
Results 1 to 6 of 6

Thread: IBM L40-SX memory size error (164)

  1. #1

    Default IBM L40-SX memory size error (164)

    Hi guys,

    I have two of these laptops and one is behaving nicely, while the other one keeps thinking there is some kind of memory size problem. The one with the memory size problem has the standard 2MB on board and a 4MB 72-pin SIMM stick. The memory size error shows up with or without the stick, so that's not the issue.

    The memory count is ok (2048K without and 6144K with). But the 164 always shows up. No matter how many times I either auto-configure with the reference floppy or set it up manually. Hitting F1 gets it to boot just fine. No indications anything is wrong, and DOS reports the right amount of memory.

    Running a check-it memory test on the base memory (2MB) now, just to rule that out. So far so good.

    Oh, and I obviously replaced the CMOS battery with a CR2032 coin cell so it keeps its CMOS parameters (which it does).

    Anyone ever run into something like this? And know how to fix it?

  2. #2

    Default

    Early IBM's like such were very picky about the RAM. Are you certain it's "100% compatible"?

  3. #3

    Default

    Yes. It's the IBM module that came with the unit. Plus the issue also occurs if the module is NOT in there and it just runs off the RAM soldered on the mainboard. Which passes the Checkit thorough test...

  4. Default

    http://ps-2.kev009.com/ohlandl/8543/...tml#ramupgrade

    Just because it came with the unit does not mean that it worked. Unless the former owner swore on a stack of HMMs that high, that it did.

    2MB Memory Module Kit 79F1002
    4MB Memory Module Kit 79F1003
    8MB Memory Module Kit 79F1004

    Retained memory error may need clear CMOS.

    164 (See “Memory Checkout” on page 25 before replacing any FRUs.)
    1. Run Automatic Configuration
    2. Memory Module Kits
    3. System Board

  5. #5

    Default

    Hi! Thanks for your reply. I have TWO of these identical laptops. The 4MB module works fine in the other one without any errors. Additionally, the 164 error shows up, even if the module is NOT inserted in the slot (and it's just running with the 2 MB that is soldered on the mainboard.

    Even though the BIOS startup complains about 164, a memory test shows that the RAM is ok, and according to DOS, everything is recognized properly.

    I have tried to reset the CMOS by disconnecting the battery and leaving it disconnected. Doing an auto-configure with the reference floppy gets everything configured, but still a 164 error (without the memory stick inserted).

    Any other suggestions?

  6. #6
    Join Date
    May 2006
    Location
    Melbourne, Australia
    Posts
    6,199

    Default

    Quote Originally Posted by rvdbijl View Post
    I have tried to reset the CMOS by disconnecting the battery and leaving it disconnected.
    I notice that you used the word, "tried", suggesting that you think you may not have been successful. If that is the case, why; you did not see 161/162 errors ?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •