Image Map Image Map
Results 1 to 10 of 10

Thread: Issues with mTCP - I'm almost there I'm sure!!

  1. #1

    Default Issues with mTCP - I'm almost there I'm sure!!

    I am running a 16bit 3Com 3C509 ISA network card. The packet driver loads and displays the correct MAC address, my network is happily handing out IP addresses to other devices but I am struggling with mTCP.

    I have tried configuring every IRQ on the network card and it still fails.

    When trying the DHCP command I get:

    "Your DHCP server never responded, but your Ethernet card is receiving packets. Check your DHCP server, or increase the timeout period."

    If I set a static (known free) IP and run a ping to 8.8.8.8 I get:

    "Timeout waiting for ARP response."

    YouTube link coming shortly to show you what is happening, I would be grateful for any advice.

    Thanks.

  2. #2

    Default

    I answered offline but feel free to chip in if you have an idea of what might be wrong. I've asked the OP to run pkttool to see what kind of packets are coming in, take a trace to see if the IP checksums are valid, and to force full-duplex on the card.

  3. #3
    Join Date
    Jan 2010
    Location
    Central VA
    Posts
    4,539

    Default

    From the YouTube clip I wonder if you don't have either an IRQ conflict or a bad Ethernet card. Seems like you're doing everything correctly.

  4. #4

    Default

    IRQ conflict is unlikely - he is receiving packets. I am wondering what state those packets are in though - a failing IP checksum would kill DHCP, Ping, etc. even though packets came in. (I advised him to get a trace so I could tell if that was happening.)

    There is also the transceiver issue - the fact that the diagnostics can't tell his connection type is odd.

  5. #5

    Default

    Thanks to the both of you.

    @Mike - I have emailed the attachments, but will include them on here for the benefit of the other forum members.

    I see a lot of reference to a network that I am not aware of (128.136.1.#), my network is 192.168.1.0/24.

    Within the zip there are two files:

    OUTPUT.TXT - standard PKTTOOL output
    OUTRAW.TXT - raw PKTTOOL output.

    PKTTOOL_output.zip
    Attached Files Attached Files

  6. #6

    Default

    Quote Originally Posted by bigfella View Post
    I am running a 16bit 3Com 3C509 ISA network card.
    You didn't say what kind of machine this is, but if the NIC is in an 8-bit ISA slot then you must make sure that the NIC is a 3C509B. The non-B variant doesn't work in 8-bit mode.
    Looking for a cache card for the "ICL ErgoPRO C4/66d V"

  7. #7
    Join Date
    Mar 2017
    Location
    New Jersey, USA
    Posts
    468

    Default

    Quote Originally Posted by bigfella View Post
    I see a lot of reference to a network that I am not aware of (128.136.1.#), my network is 192.168.1.0/24.
    This (and what I see in the text file) looks a lot like a bad card or a bad transceiver. Bits are getting flipped. the 192 octet differs from 128 by exactly 64 (1 bit). Likewise, 168 differs from 136 by exactly 32 (again, 1 bit).

  8. #8

    Default

    Thanks for the last two posters, interesting finds there - particularly around the 1 bit offset.

    Well I got it to work today, I have been in email conversation with Mike, here is the latest:

    "
    I stripped down the AUTOEXEC.BAT and CONFIG.SYS to bare essentials, slowed the CPU clock down and tried again - same issue. Tried the 3Com packet driver - same issue. I pulled out the sound card and only ran the Ethernet card - same issue. Hmmm.

    So then I thought that there must be a fault with the Ethernet card. I swapped back to the RTL8019AS (Realtek) variant card, I thought I would try the IRQ in the configuration utility as "IRQ 2/9", not heard of this before as all the others are single numbers. Low and behold it worked, using the NE2000 packet driver! So there is nothing wrong with the network kit, it was down to the card itself. I flipped back to the 3Com card, but did not have the "IRQ 2/9" option, only "IRQ 9" so I tried that - same issue again, still not working.

    I am running on the Realtek card now but as an experiment I have found a new old stock 3Com 3C509 card and purchased it on eBay so will try that. I also found a new old stock Genius GE2000III (NE2000 comptible) card for cheap that can do either jumper or jumperless so will try that too.

    Will be interesting when the new cards arrive, but thanks again.
    "

  9. #9

    Default

    Quote Originally Posted by Krille View Post
    You didn't say what kind of machine this is, but if the NIC is in an 8-bit ISA slot then you must make sure that the NIC is a 3C509B. The non-B variant doesn't work in 8-bit mode.
    Was there ever a 3905 non B version? Yes, it stands to reason that there is but I don't think I have ever seen one. In fact I am in possession of three variants/revisions of the 3C509B cards as I type this:

    3C509B.jpg

    So will all three variants work in 8bit slots?
    Current Wish List: 1. IBM 7531 Industrial Series PC 2. NEC MultiSync XL (JC-2001) Monitor 3. Copy II PC Enhanced Option Board (the one with the toggle switch on the back) 4. MicroSolutions MatchPoint AND/OR UniDOS card 5. Compaq 14" VGA CRT Monitor (the one that came with the SystemPro). If you have any of the above for sale please PM me. Thank you!

  10. #10

    Default

    Quote Originally Posted by Shadow Lord View Post
    Was there ever a 3905 non B version? Yes, it stands to reason that there is but I don't think I have ever seen one.

    And no sooner then I finish typing that I find a 3C509 in my card collection... The card is a revision A although I am not sure what that means. Going by the markings on the other cards it is a Revision A 3C509 (as I have a revision C 3C509B).
    Current Wish List: 1. IBM 7531 Industrial Series PC 2. NEC MultiSync XL (JC-2001) Monitor 3. Copy II PC Enhanced Option Board (the one with the toggle switch on the back) 4. MicroSolutions MatchPoint AND/OR UniDOS card 5. Compaq 14" VGA CRT Monitor (the one that came with the SystemPro). If you have any of the above for sale please PM me. Thank you!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •