Image Map Image Map
Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Reimaging HDD on SD card for Win 98 upgrade

  1. #11
    Join Date
    Apr 2015
    Location
    Austin, Texas
    Posts
    1,538

    Default

    Quote Originally Posted by ped View Post
    Although I'm not trying to create a FAT32 partition as the destination, was using clonezilla explicity because I wanted it to be identical. FAT16 to FAT16. Just saw that in some instances clonzilla didn't start from byte 0 when it cloned it.
    This is probably why the resulting imaged drive fails to boot, the boot sector MUST be located at the first sector of the drive. If garbage data exists on the imaged disk, it probably explain why the computer locks up trying to boot.


    Quote Originally Posted by ped View Post
    Then when I created a FAT16 partition using FDISK from a WIN95/98 boot disk, and then copied only the partition, excluding MBR over - it ran out of space?
    Not exactly sure what you're trying to do here.

    So you're saying you created a partition of a fixed size with FDISK and then tried to copy the partition data over it with clonezilla and it failed? If that's the case, clonezilla is trying to write extraneous data that doesn't belong. I think you should probably migrate to another disk imaging program.

    Quote Originally Posted by ped View Post
    However what's not clear is Win98 claims it could convert at FAT16 installation to FAT32 without issue. Does that mean it could, assuming I find some way to clone it to the SD drive, enlarge the partition through Windows / FDISK?
    Windows 98 can convert a partition to FAT32, but it can't make it bigger. You'd either have to re-partition the drive with FDISK and make larger partitions or use something like Minitool Partition Wizard to enlarge the partition on another machine.

  2. #12

    Default

    Quote Originally Posted by ped View Post
    I tried that before, problem is xcopy has issues copying long directory names over, and only 25% of the files got copied over. Not to mention it states it doesn't copy hidden or system files.
    You can back up the long file names and restore them after. The Windows 95 CD contains a tool called LFNBAK for this purpose (otherwise, the internet should know about DOSLFNBK). Also, I remember from a magazine that "XCOPY /K/R/E/I/S/C/H" will copy all files, independent of attributes. So it is definitely possible to copy the data without additional tools.

    However, instead of fighting to clone, I would opt for a clean re-install.
    Back in the days, Windows needed a reinstall every once in a while anyway.

    Or, find a copy of PowerQuest Drive Image. It can backup, resize and restore partitions from/to files.

  3. #13

    Default

    Quote Originally Posted by Svenska View Post
    Back in the days, Windows needed a reinstall every once in a while anyway.
    No it didn't, no more than it does now. I've seen many industrial machines running Win9x for over a decade without a reinstall. Users who installed and uninstalled loads of crap started that myth when their registry got so fouled up that roto-rooter couldn't clean it up.

  4. #14

    Default

    True: If you never changed the system, then you would never need a reinstall. Otherwise...

  5. #15

    Default

    Hi everyone,

    Thanks for all the replies. Again a really great group here, proven time and time again.

    So my method ended up being a follows:
    1. Booted from Win95 boot disk
    2. FDISK a FAT16 partition, rebooted
    3. FDISK /MBR and then Formatted the SD card (no /s - imporant later)
    4. Rebooted with a WinME Emergency boot disk
    5. Used XCOPY from old HDD to SD card using /S/A/E/H/V switches (which successfully copied 9000/20000 files)
    6. After that failed, then unpluged both old HDD and SD card from Pentium, hooked up to modern PC
    7. Then used ROBOCOPY using /V /E /COPYALL /MIR /IS /LOG:"filename" from HDD to SD card again
    8. After that it copied all 20K files over, except one which was COMET.DLL, an old malware that my AV caught.
    9. Booted and it worked!


    I had one registry entry that I had to update, which was an easy fix given with the 8.3 format, the directory was named with a ~1 instead of a ~2. Otherwise running just fine.

    Not sure all the steps above were critical, and perhaps could have gone straight to ROBOCOPY after formatting the SD card, but perhaps there was something in doing the XCOPY before hand. Not sure.

    I did have one scare when I heard a screw rolling around in my case after all the case lid opening / closing to reconnect my old HDD as a master on the secondary IDE channel, and then when I rebooted after the RAM check it said "WAIT...." just before checking the IDE controllers and stood there forever. After taking the case off/on again to investigate, finding nothing, it booted again.

    Perhaps the PSU is going to need replacing soon.

    Meanwhile what I did try that didn't work:
    • Using Norton Ghost 12.0 for a WIN7 VM I had - couldn't detect the drive as it wasn't local.
    • Using DSL cp * over from one device to another - 1/2 way through kept freezing
    • Trying other versions of XCOPY to get all the WIN95 directory files over - kept having errors think I only copied 1000 files before it cut out


    Never got around do doing the FreeDOS option to find the ultimate XCOPY but again if i was going to use that, it was going to be on my modern machine, and at that point why go through the hassel when I can use ROBOCOPY. The most advanced XCOPY version I could find was from the WinME boot disk and it was still missing a ton of switches.

    I did both a raw (DD) and default FAT16 disk image again of the SD card using Clonezilla for safekeeping. I'm too much of a chicken to test it immediately, nad overwrite the working SD card, but will buy another SD card and see how that works out later.

    Anyway if anything changes, I'm sure I'll be back.

    Thanks again to one and all.

  6. #16

    Thumbs up

    Figured that I'd do a quick follow-up because I ended up killing my newly converted FAT32 when I tried to enlarge the partition.

    I was heartbroken, but optimistic when I did a Clonzilla reimage using the FAT16 image of the *same* SD card, and it failed to boot.

    Then did a reimage then using DD/RAW, and it too failed to boot. (Note both images used default or beginner for "savedisk" when I took the images of the SD card) Now I was wondering if I have to pull out the poor 20+ yr old HDD again everytime I wanted to do that, and thought it was a bit absurd.
    What I did notice with Clonezilla is that it always seemed to do work, then rework the drive after the image was copied. For example it always wanted to resize the drive despite the image clearly only taking 2GB of the 8GB card. So then I decided to use the advanced options and undo anything that I thought would change the image after it was copied over.

    So using Clonezilla amd64 2.6.1-25

    IMG_9401_default.jpg
    I deselected:
    • -g auto
    • -e1 auto
    • -e2
    • -r
    • -j2

    IMG_9402_deselected.jpg
    Only leaving the -c

    IMG_9404_ddpart.jpg
    Then i set -j0 for advanced parameters allowing the dd/RAW to create the partition.

    It worked!

    So thereafter I used both Minitool partition wizard AND EaseUS partition Master 13.5 - and both of them succeeded to extend the converted FAT32 from the 2.1GB to the full 8GB SD card - however when I tried to use the SD card after this "conversion" it failed to boot. Dissapointing. So i just created a logical D: drive instead using the remaining space on the drive/card, and chalked this one up to *meh*.

    Anyway figured I'd share as this community is great and if it could someday help someone else.

    Cheers,
    Last edited by ped; July 5th, 2019 at 06:14 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •