Image Map Image Map
Page 1 of 2 12 LastLast
Results 1 to 10 of 101

Thread: PET 3032 garbage screen problem

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default PET 3032 garbage screen problem

    Hi
    My pet 3032 has the problem of garbage screen
    20190824_133701.jpg

    I have checked all pcb voltages and they are correct. + 5V, + 12V, -5V and + 9V, according to the diagrams:
    http://www.zimmers.net/anonftp/pub/c...N/320349-1.gif
    to
    http://www.zimmers.net/anonftp/pub/c...N/320349-8.gif

    I have checked the ram and roms with the http://blog.tynemouthsoftware.co.uk/...nt-boards.html and they are ok.
    20190824_140644.jpg

    When boot with replacement boards the same


    The difference is that if I press the reset button on the replacement board it loads the basic screen but with garbage, whether I use the board roms/rams or replaced roms/rams
    20190824_141100.jpg

    Help me please

  2. #2

    Default


  3. #3

    Default

    If RAM and ROMs are ok (but I doubt they can be safely tested from a daughterboard, having made my own daughterboard too), then this looks like a data (or even address/decode) conflict with some other parts. It could be an I/O chip or maybe a data bus transceiver (74LS244) or it might be an address bus buffer failing or any part of address decoding logic faiiling. Do you have an oscilloscope or logic probe?
    Frank IZ8DWF

  4. #4

    Default

    Yes, I have an osilloscope. What should i check? What chips? What pins? What values?

  5. #5
    Join Date
    Feb 2009
    Location
    Southern California, USA
    Posts
    2,690

    Default

    Quote Originally Posted by Fran View Post
    Yes, I have an osilloscope. What should i check? What chips? What pins? What values?
    I agree with Frank that because of the alternating inverse video, and repeating patterns, etc. there may be an addressing logic issue rather than bad RAM. Can someone post the info about making a simple NOP Generator so that the address lines can be easily traced?

  6. #6
    Join Date
    Dec 2005
    Location
    Toronto ON Canada
    Posts
    7,201

    Default

    Here's the wiring; use a 40-pin socket, bend out the appropriate pins and run the wires around the outside so you can insert the 6502.



    An interesting blog, although the link to the instructions seems to be dead:

    http://www.8bit-homecomputermuseum.a...t/bluepet.html

  7. #7
    Join Date
    May 2018
    Location
    Lancashire
    Posts
    259

    Default

    Quote Originally Posted by Fran View Post
    Yes, I have an osilloscope. What should i check? What chips? What pins? What values?
    Ive had some luck with https://www.amazon.co.uk/gp/product/...?ie=UTF8&psc=1

    Just used it to resolve a problem with my Apple II as the ram was not being written to sucessfully, was quite satisfying to trace the logic visually.

    It turned out I had used the wrong PC ATX supply and didnt have a -5V !

  8. #8
    Join Date
    Dec 2005
    Location
    Toronto ON Canada
    Posts
    7,201

    Default

    Not sure why you need two sockets; bending out the pins disconnects the data lines from the board although you might want to put a piece of paper under the socket to avoid inadvertent contact with the bent pins.

  9. #9

    Default

    Quote Originally Posted by iz8dwf View Post
    If RAM and ROMs are ok (but I doubt they can be safely tested from a daughterboard, having made my own daughterboard too), then this looks like a data (or even address/decode) conflict with some other parts. It could be an I/O chip or maybe a data bus transceiver (74LS244) or it might be an address bus buffer failing or any part of address decoding logic faiiling. Do you have an oscilloscope or logic probe?
    Frank IZ8DWF
    Commodore PET ROM / RAM replacement board https://d3s5r33r268y59.cloudfront.ne...er%20Guide.pdf
    This board has 9 DIP switches:
    1-2 - RAM replacement options
    3-5 - ROM replacement options
    6-9 - ROM selection

    used switches
    1-2 ON (pcb Ram replaced by Ram board)
    3- ON 4-5 OFF (pcb Roms replace by Roms board)
    7- ON 6-8 OFF (BASIC 2)

    In this scenario the pet uses the ram and roms of the replacement board....

    NOP generator made with the MikeS scheme

    20190826_213904.jpg

    Quote Originally Posted by dave_m View Post
    A0 will have the highest frequency of about 500 KHZ, A1 half of that, and A2 half of A1. If you spot something not in that pattern, you have found the problem. Note however that the RAM address inputs are multiplexed with the dynamic RAM refresh logic so it gets a little messy there. Hopefully with this method you will spot a bad buffer or whatever.
    The frequency at A0 (6502 pin9) is 250Khz, is it correct?

    SDS00001.jpg

  10. #10

    Default

    Quote Originally Posted by Fran View Post
    Commodore PET ROM / RAM replacement board https://d3s5r33r268y59.cloudfront.ne...er%20Guide.pdf
    This board has 9 DIP switches:
    1-2 - RAM replacement options
    3-5 - ROM replacement options
    6-9 - ROM selection

    used switches
    1-2 ON (pcb Ram replaced by Ram board)
    3- ON 4-5 OFF (pcb Roms replace by Roms board)
    7- ON 6-8 OFF (BASIC 2)

    In this scenario the pet uses the ram and roms of the replacement board....
    I used this configuration to verify that the garbage error was not caused by the ram or roms.

    With the NOP generator I am using the ram and roms of the pet.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •