Image Map Image Map
Results 1 to 4 of 4

Thread: IBM 5160 keyboard issues...

  1. #1
    Join Date
    Aug 2016
    Location
    Turin, Italy
    Posts
    121

    Default IBM 5160 keyboard issues...

    Dear All,

    my beloved IBM 5160 has a keyboard illness!
    In the past I supposed the issue was related to the keyboard itself but today I am afraid the issue is related to the computer!
    The problem seemed solved changing the keyboard and infact today I was working with a NEW keyboard... but without any advise the keyboard stopped working: after a reboot I got error 301 at the startup!
    I tried other XT class keyboards but no results at all... only the feared (by me) 301 error, without any other number (that would be related to a pressed key).
    I looked over the internet and the best I have found is on my beloved minuszerodegrees site:
    No keyboard attached. ==>> the keyboards were attached (almost sue... I have tried 2 more apart the original one)
    AT class keyboard attached. That will not work. A PC/XT class keyboard is required. ==>> the keyboards are XT class
    Faulty keyboard - broken wire in cable. ==>> I have tried with different keyboards
    Faulty keyboard - wire loose in connector. ==>> I have tried with different keyboards
    Faulty keyboard - chip failure. ==>> I have tried with different keyboards
    Faulty motherboard - bad solder joint on keyboard connector. ==>> possible (I hope this is the issue...)
    Faulty motherboard - faulty keyboard circuitry. ==>> any help about this point?

    I would like to understand if I am missing something!
    And some help, especially if somebody had the same issue in the past!

    I think the main point is that the keyboard stopped working while I was using it (testing some CGA games)...

    Thank you

  2. #2
    Join Date
    Jan 2007
    Location
    Pacific Northwest, USA
    Posts
    31,976
    Blog Entries
    18

    Default

    It isn't uncommon for the 5-pin DIN connector on the motherboard to succumb to stress in its solder connections. Carefully check those; buzz out the entire trace for each lead. Chances are that you'll find the problem. The keyboard circuitry on the 5160 is very simple--essentially a shift register connected to a port on the 8255. Squirt a bit of contact cleaner into the connector while you're at it.

  3. #3

    Default

    I'm having some similar difficulties right now trying to get any keyboard working with my IBM 5160. Great advice on the DIN connector...I'll definitely be checking that.

    I do have a question...can you damage anything (keyboard, motherboard, etc) by plugging the wrong type of keyboard in?

    My sense is that you can't...the communication protocol just isn't right...but I really want to make absolutely certain before I do a certain test and risk one of my only working vintage keyboards (I literally don't know if it's an XT or AT keyboard)

    Thanks!

  4. #4
    Join Date
    May 2006
    Location
    Melbourne, Australia
    Posts
    6,286

    Default

    Quote Originally Posted by MikeTwain View Post
    I do have a question...can you damage anything (keyboard, motherboard, etc) by plugging the wrong type of keyboard in?
    For the scope of IBM 5160 and XT-class keyboards and AT-class keyboards, the answer is no.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •