Image Map Image Map
Page 39 of 43 FirstFirst ... 29353637383940414243 LastLast
Results 381 to 390 of 424

Thread: Commodore pet 3032 screen full of lines

  1. #381

    Default

    Quote Originally Posted by dave_m View Post
    We’ll need to check the recorded checksums from pettiest vs the known good values, as a ROM maybe bad. I forget, do you have new ROM installed or originals?
    I have two originals edit rom, with one i see only black screen and with the others i see full scrambled chars screen

  2. #382

    Default

    News!
    I inserted cia and via chips and now Pet lives
    Unfortunately ram kb on the screen are not always the same size but change every boot up....
    The basic words are very disturbed
    and i also hear a little buzz noise.....

    Im very happy to results and
    thank you very much to all, especially daver2!

    20191017_234909.jpg
    20191017_234920.jpg
    20191017_234952.jpg

  3. #383
    Join Date
    Jun 2012
    Location
    UK - Worcester
    Posts
    3,155

    Default

    Just got back from my business trip from the cold and dark North West of England.

    I see you are starting to get some success now (and I missed all of the action)!

    I will check the EPROM checksums and your video when I get home (I can't do those things from work).

    One thing I did notice is the '17' values read back from the keyboard matrix. All of these values should be 00. I suspect a bad keyboard or (more likely) a bad keyboard PIA (UC7) and/or IC socket.

    So it looks like the 164 was the memory culprit. That was a pretty 'evil' problem to track down - as we would see both /RAS and /CAS signals present on the RAMS - it is just that the /RAS was present during a refresh cycle but *** NOT *** present for the memory access cycle itself (therefore not storing anything to - or reading anything back from - the RAM)...

    I'll have a more in-depth read when I get back home and suggest a few more things to see if we can get the machine a bit more healthy.

    But, well done for getting this far.

    Thanks to everyone for the kind words!

    Dave

  4. #384

    Default

    Quote Originally Posted by daver2 View Post
    Just got back from my business trip from the cold and dark North West of England.

    I see you are starting to get some success now (and I missed all of the action)!

    I will check the EPROM checksums and your video when I get home (I can't do those things from work).

    One thing I did notice is the '17' values read back from the keyboard matrix. All of these values should be 00. I suspect a bad keyboard or (more likely) a bad keyboard PIA (UC7) and/or IC socket.

    So it looks like the 164 was the memory culprit. That was a pretty 'evil' problem to track down - as we would see both /RAS and /CAS signals present on the RAMS - it is just that the /RAS was present during a refresh cycle but *** NOT *** present for the memory access cycle itself (therefore not storing anything to - or reading anything back from - the RAM)...

    I'll have a more in-depth read when I get back home and suggest a few more things to see if we can get the machine a bit more healthy.

    But, well done for getting this far.

    Thanks to everyone for the kind words!

    Dave

    Welcome back Daver2!
    I love dark and cold England Wheater....
    Keyboard was disconnected when i used pettester.....
    I don't understand because ram size are not the same...

  5. #385
    Join Date
    Jun 2012
    Location
    UK - Worcester
    Posts
    3,155

    Default

    Ok,

    So, the ROM checksums are good for BASIC 2 (7800 3838 506a 7c98).

    If you didn't have a keyboard connected, then the keyboard PIA must be duff (or something else is causing the '17' displays).

    The usual reason for varying memory sizes on startup is faulty RAM. I noticed in the video you made of my PETTEST running that you terminated the video before the 1st pass had completed. Can I suggest that you put my PETTEST ROM back in and get at least 10 good passes of the test?

    Dave

  6. #386

    Default

    Quote Originally Posted by daver2 View Post
    Ok,

    So, the ROM checksums are good for BASIC 2 (7800 3838 506a 7c9.

    If you didn't have a keyboard connected, then the keyboard PIA must be duff (or something else is causing the '17' displays).

    The usual reason for varying memory sizes on startup is faulty RAM. I noticed in the video you made of my PETTEST running that you terminated the video before the 1st pass had completed. Can I suggest that you put my PETTEST ROM back in and get at least 10 good passes of the test?

    Dave

    I tried to do the pettest again but it seems to never end ... how long does the test usually take, 1 hour?

  7. #387

    Default

    Update:
    1.jpg
    2.jpg

  8. #388
    Join Date
    Jun 2012
    Location
    UK - Worcester
    Posts
    3,155

    Default

    The memory test takes forever (!) it tests all of memory all of the time in a loop. You should get an incrementing PASS counter every time it successfully completes one entire memory pass.

    I see your keyboard values have now gone to 00. How did you do that?

    The last image you have is a memory error detected at address $4b33. Data Bit 1 was in error. It should have been a '1' but was observed to be a '0'.

    If I remember correctly, you replaced bank 0 - but left bank 1 in place didn't you?

    Dave

  9. #389
    Join Date
    May 2018
    Location
    Lancashire
    Posts
    260

    Default

    Quote Originally Posted by daver2 View Post
    Just got back from my business trip from the cold and dark North West of England.

    Dave
    It wasn't that bad today !

    were you next door ?

  10. #390
    Join Date
    Jun 2012
    Location
    UK - Worcester
    Posts
    3,155

    Default

    I came back this morning. Over on 2 on Wed and then at a contractor's on Thu.

    We must go out for a curry next time I am up. The regular haunt is the Bombay Balti.

    Dave

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •