Image Map Image Map
Page 42 of 43 FirstFirst ... 32383940414243 LastLast
Results 411 to 420 of 425

Thread: Commodore pet 3032 screen full of lines

  1. #411

    Default

    Now we are on pass 00007 and it's ok....
    but screen are disturbed....words wobble and flicker on the screen...

  2. #412
    Join Date
    Jun 2012
    Location
    UK - Worcester
    Posts
    3,178

    Default

    I don't care about the screen wobbling at this point in time - we are testing the RAM for now. Can we concentrate on one problem at a time please.

    Let's get to memory pass 20 without an error and we can then move on from there - but pass 7 without an error is looking promising.

    Can you remember which pin was bent?

    Dave

  3. #413

    Default

    Quote Originally Posted by daver2 View Post
    I don't care about the screen wobbling at this point in time - we are testing the RAM for now. Can we concentrate on one problem at a time please.

    Let's get to memory pass 20 without an error and we can then move on from there - but pass 7 without an error is looking promising.

    Can you remember which pin was bent?

    Dave

    Ok, maybe pin number 9

    Now screen show pass 0000c.

  4. #414
    Join Date
    Jun 2012
    Location
    UK - Worcester
    Posts
    3,178

    Default

    Pin number 9 = +5V supply. That definitely wouldn't have done the memory chip any good !

    >>> Now screen show pass 0000c.

    Excellent. Keep going...

    Dave

  5. #415

    Default

    Quote Originally Posted by daver2 View Post
    Pin number 9 = +5V supply. That definitely wouldn't have done the memory chip any good !

    >>> Now screen show pass 0000c.

    Excellent. Keep going...

    Dave

    DAVER2 now we are at 000026 pass......can i stop?

  6. #416
    Join Date
    Jun 2012
    Location
    UK - Worcester
    Posts
    3,178

    Default

    Yep, you can stop now. That looks good to me.

    The next thing is to test the keyboard PIA and keyboard itself.

    Reset the PET and get the ROM checksum and keyboard test screen up with the count down counter ticking away.

    Press each key in turn on the keyboard - and you should see a single '1' bit appear for each key pressed. If you don't get a '1' displayed then it is possible that the key is not working correctly, or there is something wrong with the row/column matrix logic.

    When you have done that report your findings back please.

    If the counter counts down to zero (and starts the memory test) before you have finished your key testing, you will have to reset the PET again.

    Dave

  7. #417

    Default

    Daver2 keyboard works correctly....i
    I've already tried all the keys on the basic screen

  8. #418
    Join Date
    Jun 2012
    Location
    UK - Worcester
    Posts
    3,178

    Default

    OK,

    PETTEST out of EDIT socket and EDIT ROM back into EDIT socket.

    Test PET with BASIC and see what the 'bytes free' message says.

    Dave

  9. #419

    Default

    Yes!!Finally!
    I found the last culprit!
    Looking at the ram schematic, I tried to piggyback the two 244s and fortunately I saw that with one of these, the defect disappeared..
    so i changed UH10 and now i have all ram size and not disturb or noise

    Daver2 thanks so much for your precious help and thanks to the other members!
    Now another Pet alive!!

    Daver2 excuse me but i must open another post unfortunately.....i have a 8032sk 100% workling but monitor board don't works and i can't see anything at screen
    20191019_210649.jpg
    20191019_210751.jpg

  10. #420
    Join Date
    Jun 2012
    Location
    UK - Worcester
    Posts
    3,178

    Default

    Good news!!!

    >>> Daver2 thanks so much for your precious help and thanks to the other members!

    No problems. Enjoy your machine...

    I assume you mean UI10 rather than UH10?

    It is interesting why UI10 didn't appear faulty when we were doing the memory testing - as it buffers data lines 0 through 3?!

    Presumably that cured the screen issues as well did it???

    >>> but monitor board don't works and i can't see anything at screen

    I remember that machine. I will let someone else have a go at that whilst I get on with another project.

    Dave

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •