Image Map Image Map
Results 1 to 5 of 5

Thread: Disk Directory Issue, Sol-20

  1. #1

    Default Disk Directory Issue, Sol-20

    I have been using a workhorse 5.25 floppy disk over the last few months in my YD-580 drives & VSG with the Northstar double density controller & Sol-20.

    A couple of months ago an odd file format turned up in the directory "9999 99" I had no idea what this was or how it came about. Also I could not erase it with any combinations like ERA 9999.99 etc. I have attached a photo.

    Out of the blue today a lot of other listings appeared, this time IIII II, as can be seen in the photo. Once again these don't appear to do anything, are not possible to erase either, and all the other files/programs on the disk are working normally with no errors at all, so I think the drives and this disk are in good condition.

    Has anyone seen this before or knows what it means or how it could come about ?

    Recently I have been writing some programs for the first time to take data from specific memory areas to the disk, but the initial 9999 99 event turned up long before this.
    Attached Images Attached Images

  2. #2

    Default

    I can't say that I've seen this or even worked with a SOL-20. However, having worked with CP/M I would suspect that the solution lies in trying to figure out why the column alignment for the directory entries has changed. Is it possible there's a non-ASCII character embedded in the name? First thing I'd do is to dump the first directory block in hex / ASCII and inspect these names.

  3. #3

    Default

    Now I feel like I asked a daft question. Only the day or two before I noticed these oddball effects in the directory listing, a problem had cropped up in the SOL where the 8V line collapsed in use. At the moment it did it, and it did it a number times, the Sol's fan sped up just a little.

    I could see the voltage on the 8V drop to zero because in my sol I have installed a small LED volt meter to monitor the 8V line and I had the top off the unit, but it also had the disk in the drive when it did it a number of times.

    I traced the problem to a faulty crimp on the white wire of the spade terminal that attaches to the bolt down bridge rectifier (photo attached), what had happened (after I cut it open to see) is that it had largely been crimped around the plastic insulation and the short area of bare stands was just sitting flush in there in the connector and not properly crimped.

    The collapsing and returning voltage must have played havoc with the Northstar controller card. The crimps on one of the transformer wires was sloppy, but at least it was still connected. I fitted 4 new connectors & soldered them.

    No doubt when that 9999 99 turned up some months ago it was just an example of one of those power loss events that I did not notice, except for the oddball effect on the directory with the 9999 99 in there.

    I can't believe I didn't initially make the connection between the two events, but I had not looked at the disk directory immediately after the 8V power fail events, and the programs on the disk, that I had been using, were all working, so I didn't realize anything had happened to it until I checked the directory over a day later. All the files on the disk appear undamaged (that I have tried so far) I transferred them to another disk.
    Attached Images Attached Images
    Last edited by Hugo Holden; September 16th, 2019 at 04:10 AM.

  4. #4
    Join Date
    Mar 2013
    Location
    Chaffee, MO
    Posts
    1,234

    Default

    It's a good thing you found the problem before further corrupting your Floppy Images beyone repair.
    Hopefully you didn't loose any of your files.

    I've got a floppy with a corrupt directory that was also caused by something:
    Code:
    00002800   02 00 00 E5  E5 E5 E5 E5  E5 E5 E5 E5  E5 E5 E5 E5  ................
    00002810   E5 E5 E5 E5  E5 E5 E5 E5  E5 E5 E5 E5  E5 E5 E5 E5  ................
    00002820   00 4D 4F 56  43 50 4D 20  20 43 4F 4D  00 00 00 6E  .MOVCPM  COM...n
    00002830   02 03 04 05  06 07 08 09  0A 0B 0C 0D  0E 0F 00 00  ................
    00002840   00 53 59 53  47 45 4E 20  20 43 4F 4D  00 00 00 10  .SYSGEN  COM....
    00002850   10 11 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
    00002860   00 46 4F 52  4D 41 54 20  20 43 4F 4D  00 00 00 14  .FORMAT  COM....
    00002870   12 13 14 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
    00002880   00 43 4F 50  59 20 20 20  20 43 4F 4D  00 00 00 12  .COPY    COM....
    00002890   15 16 17 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
    At least I can easily recover the files.

    Larry

  5. #5

    Default

    Quote Originally Posted by ldkraemer View Post
    It's a good thing you found the problem before further corrupting your Floppy Images beyone repair.
    Probably some of the files/programs could be damaged too and I haven't detected that yet, so I think I will replace them with the originals and reassemble my programs just to be 100% sure, or I might get caught out later.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •