Image Map Image Map
Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: PET 8032 - Blank Screen / Lines at full brightness

  1. #11
    Join Date
    Jun 2012
    Location
    UK - Worcester
    Posts
    2,978

    Default

    The video circuitry looks good !

    Let's see if we can get you a copy of my diagnostic EPROM. This replaces the EDIT ROM in the machine (this ROM definitely should be in a socket).

    I can't burn EPROMS myself at the moment, but I know someone who can. He is somewhat busy at the moment (and he lives in Cheadle) so I will only be able to do this when I see him next.

    You can make a NOP generator by purchasing a spare 6502 CPU, bending out the data bus pins and wiring them to VCC and GND (via low-valued resistors - 8 off) in a pattern to fool the CPU into thinking that it is executing a NOP instruction ($EA). You can then swap the PETs 6502 CPU for your NOP generator replacement (assuming the CPU is in a socket that is). A few more pounds than a couple of IC sockets possibly.

    Dave

  2. #12

    Default

    Hi Dave

    I'm in Kent, But if you let me know the costs and if it's possible to mail it down I can send the money over to you

    Would the 65C02 be an appropriate base for a NOP generator or would I need an original 6502? The CPU is in a socket so i'll give it a go either way

  3. #13

    Default

    Quote Originally Posted by sabrent View Post
    You suspect correctly, I'm not sure how I misread that, I'm still looking for the board diagram, I've found one on commodore.ca, but the video connector isn't in the same location




    The website isn't loading for me in the UK, Connection gets reset after about 30 seconds


    In rather bizarre news it's managed to fix it's own video signal after being on for about 15 minutes, and i'm now getting this with the beep, but it only stays for about half a second so I had to snap the picture out of a video
    Attachment 56161
    If it starts with a random screen, beeps and then clears completely the screen without anything appearing, it's more likely one of the basic ROMs that failed or its addressing logic.
    You should run a diagnostic ROM that can test the other ROMs, or test the ROMs out of circuit with a suitable reader.
    Frank

  4. #14
    Join Date
    Feb 2009
    Location
    Southern California, USA
    Posts
    2,662

    Default

    Here is a source for the 8032 schematics, parts list, and top assembly : http://www.zimmers.net/anonftp/pub/c...iv2/index.html

  5. #15
    Join Date
    Jun 2012
    Location
    UK - Worcester
    Posts
    2,978

    Default

    I have some brand new 2716s at work I got made (encapsulated) in 2016 from original Intel die stock.

    If I can persuade someone at work to program one for you I will send it to you free of charge.

    I'll see what I can do early next week.

    Dave

  6. #16

    Default

    Hi Dave

    Thanks for this, Let me know if there's anything you need from me

    Much appreciated

  7. #17

    Default

    Hi Dave, Sounds great! Let me know if there's there's anything you need from me

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •