Image Map Image Map
Page 4 of 4 FirstFirst 1234
Results 31 to 36 of 36

Thread: Imsai 8080 cannot examine to RAM adress...

  1. #31

    Default

    Hi Jan
    Most strange. The three reads are:

    00000000 should be 00111100
    10010011 should be 00000000
    00001111 should be 11110000 ( assuming you have the four left address switches up and the rest down.
    I get the feeling that you may have your data line swapped but that is not the major issue.
    I'm wondering is we have some data contention. Can we add two more signals. On the CPU card, can we see B9-15 and B9-1 ( or B8-15 and B8-1, which ever is convenient ).
    Dwight

  2. #32

    Default

    No, all 16 switches were down. Now, it´s 1.20 AM o´clock in germany. I´ll make the measurement tomorrow and let you know.

    Like i said, i wrote small programm C3 00 F0 in memory location 0000. After hit reset and three times "single step" and can see the 4 LEDs on the left side. So, adress bus is on F000. When i hit reset and press examine one time, i get the same result. So, hitting examine run the program for 3 steps. So, it runs the small program for three steps from the actual adress..


    Jan

  3. #33

    Default

    If you want to read the values your self, print the screen out and draw lines as follows"
    The data under 6us is the C3 time.
    The data ubder 8us is the low address
    The mark between 9us and 1us it the high address
    Now we are seeing what the processor is reading.
    Dwight

  4. #34

    Default

    Quote Originally Posted by Jan1980 View Post
    No, all 16 switches were down. Now, it´s 1.20 AM o´clock in germany. I´ll make the measurement tomorrow and let you know.

    Like i said, i wrote small programm C3 00 F0 in memory location 0000. After hit reset and three times "single step" and can see the 4 LEDs on the left side. So, adress bus is on F000. When i hit reset and press examine one time, i get the same result. So, hitting examine run the program for 3 steps. So, it runs the small program for three steps from the actual adress..


    Jan
    We've known that it can run programs so that part is expected to work. We just seem to be hung on getting it to read anything from the switches in the Examine sequence. Since we have seen the switches for the high address working in your program, we should be able to see them load on the read of the last address. If you had all the switches down, it is surely strange. What I'm thinking is that for some reason we are not disabling the bus drivers while we are trying to load from the switches in the sequence. It does work for entering data though.
    Dwight

  5. #35

    Default

    Hello.

    I fixed the problem. My Imsai works now !

    At the end, the problem was the U15 7427. The problem was the logic output on Pin 12.




    1000 thanks for your help Dwight ! I learned a lot !


    Jan

  6. #36

    Default

    I hope my wanting to look at the CPU's pins B9-1 and B9-15 helped to lead you in the right direction. I couldn't explain it any other way than buss contention. We were on the right track anyway. We were running out of possibilities.
    Dwight

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •