Image Map Image Map
Page 8 of 8 FirstFirst ... 45678
Results 71 to 78 of 78

Thread: Imsai 8080 cannot examine to RAM adress...

  1. #71

    Default

    Not all cpu cards are compatible with the front panel. As I recall, it has something to do with the write signals used.
    What MPU boards are you using. Is it an IMSAI MPU board and does it have any cuts and jumpers?
    Dwight

  2. #72

    Default

    Both the working and non working MPU cards are the same, IMS MPU-A rev 4. Only difference, is, non working MPU has a NEC D8080A and the working MPU has an Intel C8080A.

    Bad MPU Board 2.jpg

  3. #73

    Default

    Quote Originally Posted by Novell2NT View Post
    Both the working and non working MPU cards are the same, IMS MPU-A rev 4. Only difference, is, non working MPU has a NEC D8080A and the working MPU has an Intel C8080A.

    Bad MPU Board 2.jpg
    That shouldn't make any difference. I'll take a look at the schematic tomorrow. I'm a little under the weather.
    Do you have an EPROM board and is the memory static?
    Dwight

  4. #74

    Default

    A3 is a likely source of problems, on the CPU board. A2 can also fail. The address is generated by the CPU but the write data has to go through the bidirectional buffer on the CPU board. If the enable or the direction control doesn't work right, you get a FF into the memory.
    I assume you are able to read random memory values but the go to FF when you try to write to them. The fact that you can see values other than FF means the enable on the bidirectional buffer it working, only that the direction is not turning around during a write. This would indicate a fault in A2-6 driving DIEN* or A3 has a problem driving A2. When doing a DEPOSIT, you should see a pulse on A2-6.
    Dwight

  5. #75

    Default

    Sorry, I did not get this message. I am not seeing random values, on the Bad MPU board. It always reads FF on the data lines.

    Oh, I just noticed something very weird... Both boards, have the same two different diodes. However they are located in opposite positions.
    The 1N914/Blue, black on the Good MPU board, is in position CR1, on the bad MPU board, the same 1N914/Blue, black diode is located at location CR2. Whereas the 1N751A Zener Diode is located at CR2 on the Good MPU board and located at CR1 on the Bad MPU.

    It seems that CR2 only regulates the -5V attached to the 8080, which looks good on both boards. However, CR1 is attached to +5 and I think the phase 1 signal, so I am guessing, it could be throwing the timing off a little.
    What do you think about the diodes being installed in the wrong positions?

    It appears that the two diodes, on the Bad MPU Board should be swapped.
    What do you think?

    Good MPU Board
    Good MPU.jpg
    Bad MPU Board
    Bad MPU Board 2.jpg
    Last edited by Novell2NT; February 12th, 2020 at 10:08 AM.

  6. #76

    Default

    I'm not sure which is which. The one in the center should be the signal diode,1N914 or similar.
    The one it the upper left should be a zener diode.
    These should be swapped if wrong. Use care not to break them.
    Dwight

  7. #77

    Default

    Were you able to confirm that the CR1 diode, in the center of the board, is in fact connected to the phase 1 line as well as the 5V line?
    My big concern, is trying to get them to fit, in their correct position, after being cut short to fit, the position that they are in. That does not leave any room
    to work with at all. It will probably end up being basically surface mounted.


    IMSAI MPU layout.jpg


    Thank you.

  8. #78

    Default

    It is just a typical 100PIV signal diode. The modern replacement is the 1N4148. It is there as an overshoot clamp.
    The other option is to add a pigtail. It is connected as you describe, band on the signal line and a resistor to +5V on the other.
    It should not be connected directly to +5V. It should go through the resistor next to it.
    Dwight
    Last edited by Dwight Elvey; February 12th, 2020 at 02:27 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •